NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

CVE-2026-33729 — openfga

Fix: openfga/openfga@049b50c

CVE-2026-33729 is a Improper Input Validation vulnerability in github.com/openfga/openfga. A fix is available for github.com/openfga/openfga — see the affected versions and patch details below.

OpenFGA has an Authorization Bypass through cached keys

Also known asGHSA-h6c8-cww8-35hfGO-2026-4857
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33729.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.27%0.54%0.81%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐹github.com/openfga/openfga

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Description

In OpenFGA, under specific conditions, models using conditions with caching enabled can result in two different check requests producing the same cache key. This can result in OpenFGA reusing an earlier cached result for a different request.

Am I Affected?

Users are affected if the following preconditions are met:

  1. The model has relations which rely on condition evaluation.
  2. Caching is enabled.

Fix

Upgrade to OpenFGA v1.13.1.

Acknowledgement

OpenFGA would like to thank @Amemoyoi for the discovery and responsible disclosure.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/openfga/openfgaall versions1.13.1go get github.com/openfga/openfga@v1.13.1

Affected Products

1 product · 1 configurations
Application
openfgaopenfga
< 1.13.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openfga/openfga, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/openfga/openfga to 1.13.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33729 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Description In OpenFGA, under specific conditions, models using conditions with caching enabled can result in two different check requests producing the same cache key. This can result in OpenFGA reusing an earlier cached result for a different request. ### Am I Affected? Users are affected if the following preconditions are met: 1. The model has relations which rely on condition evaluation. 1. Caching is enabled. ### Fix Upgrade to OpenFGA v1.13.1. ### Acknowledgement OpenFGA would like to thank @Amemoyoi for the discovery and responsible disclosure.
O3 Security · Impact-Aware SCA

Is CVE-2026-33729 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2026-33729: openfga — Fixed in 1.13.1