CVE-2026-24851 — openfga
Fix: openfga/openfga@1bb5eddCVE-2026-24851 is a CWE-863 vulnerability in github.com/openfga/openfga. A fix is available for github.com/openfga/openfga — see the affected versions and patch details below.
OpenFGA Improper Policy Enforcement
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-24851.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
github.com/openfga/openfgaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
OpenFGA v1.8.5 to v1.11.2 ( openfga-0.2.22 <= Helm chart <= openfga-0.2.51, v.1.8.5 <= docker <= v.1.11.2) are vulnerable to improper policy enforcement when certain Check calls are executed.
Affected Users
Users are affected by this vulnerability if all of the following preconditions are met:
- OpenFGA v1.8.5 to v1.11.2 is being used
- The model has a relation directly assignable by a type bound public access and assignable by type bound non-public access
- A tuple is assigned for the relation that is a type bound public access
- A tuple is assigned for the same object with the same relation that is not type bound public access
- A tuple is assigned for a different object that has an object ID lexicographically larger with the same user and relation which is not type bound public access
Fix
Upgrade to v1.11.3. This upgrade is backwards compatible.
Workaround
None
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/openfga/openfga | ≥ 1.8.5&&< 1.11.3 | 1.11.3go get github.com/openfga/openfga@v1.11.3 |
Affected Products
helm chartsopenfgaopenfgaopenfgaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openfga/openfga, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/openfga/openfga to 1.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-24851 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-24851 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2026-24851 in your dependencies?
Find it across Go, including transitive dependencies.