CVE-2026-33218 — nats-server
HIGHCVE-2026-33218 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in github.com/nats-io/nats-server/v2. A fix is available for github.com/nats-io/nats-server/v2 — see the affected versions and patch details below.
NATS has pre-auth server panic via leafnode handling
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33218.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-server/v2🐹github.com/nats-io/nats-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Background
NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing.
The nats-server allows hub/spoke topologies using "leafnode" connections by other nats-servers.
Problem Description
A client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication.
Affected Versions
Any version before v2.12.6 or v2.11.15
Workarounds
- Disable leafnode support if not needed.
- Restrict network connections to your leafnode port, if plausible without compromising the service offered.
References
- This document is canonically: https://advisories.nats.io/CVE/secnote-2026-10.txt
- GHSA advisory: https://github.com/nats-io/nats-server/security/advisories/GHSA-vprv-35vv-q339
- MITRE CVE entry: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2026-33218
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/nats-io/nats-server/v2 | all versions | 2.11.15go get github.com/nats-io/nats-server/v2@v2.11.15 |
| 🐹Go | github.com/nats-io/nats-server/v2 | ≥ 2.12.0-RC.1&&< 2.12.6 | 2.12.6go get github.com/nats-io/nats-server/v2@v2.12.6 |
| 🐹Go | github.com/nats-io/nats-server | all versions | No fix |
Affected Products
nats-serverlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/nats-io/nats-server/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/nats-io/nats-server/v2 to 2.11.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33218 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2026-33218 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Multicluster Global Hub 1.4.9 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1779579439 | RHSA-2026:22347 |
| Multicluster Global Hub 1.6.5 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1780167118 | RHSA-2026:23345 |
| Red Hat multicluster global hub 1.5.3 | multicluster-globalhub/multicluster-globalhub-grafana-rhel9:1778867753 | RHSA-2026:21769 |
Frequently Asked Questions
Is CVE-2026-33218 in your dependencies?
Find it across Go, including transitive dependencies.