CVE-2026-33210 — json
CVE-2026-33210 is a CWE-134 vulnerability in json. A fix is available for json — see the affected versions and patch details below.
Ruby JSON has a format string injection vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33210.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
json💎json💎jsonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A format string injection vulnerability than that lead to denial of service attacks or information disclosure, when the allow_duplicate_key: false parsing option is used to parse user supplied documents.
This option isn't the default, if you didn't opt-in to use it, you are not impacted.
Patches
Patched in 2.19.2.
Workarounds
The issue can be avoided by not using the allow_duplicate_key: false parsing option.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | json | ≥ 2.18.0&&< 2.19.2 | 2.19.2bundle update json --conservative |
| 💎RubyGems | json | ≥ 2.16.0&&< 2.17.1.2 | 2.17.1.2bundle update json --conservative |
| 💎RubyGems | json | ≥ 2.14.0&&< 2.15.2.1 | 2.15.2.1bundle update json --conservative |
Affected Products
jsonruby-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for json, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update json to 2.19.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33210 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
A format string injection flaw was identified in Ruby JSON. This vulnerability allows a remote attacker to cause a denial of service or disclose sensitive information when processing specially crafted user-supplied documents with the `allow_duplicate_key: false` parsing option enabled. Red Hat Enterprise Linux 9.9…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | ruby4.0-0:4.0.3-34.el10_2 | RHSA-2026:20606 |
| Red Hat Enterprise Linux 9 | ruby:4.0-9080020260513131334.9 | RHSA-2026:20596 |
| Red Hat Hardened Images | ruby4-0-main-0.3.2-37.2.hum1 | RHSA-2026:57565 |
Frequently Asked Questions
Is CVE-2026-33210 in your dependencies?
Find it across RubyGems, including transitive dependencies.