NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2020-10663 — json

HIGH

CVE-2020-10663 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in json. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for json — see the affected versions and patch details below.

Unsafe object creation in json RubyGem

Also known asGHSA-jphg-qwrw-7w9g
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
5.39%6.03%6.67%7.31%5.9%6.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎json

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsjsonall versions2.3.0bundle update json --conservative

Affected Products

5 products · 7 configurations
OS
macosapple
1 version
11.0.1
OS
debian linuxdebian
2 versions
8.010.0
OS
fedorafedoraproject
2 versions
3031
Application
jsonjson_project
≤ 2.2.0
range
OS
leapopensuse
1 version
15.1
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for json, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update json to 2.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10663 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat CloudForms 5 uses vulnerable rubygem-json, however, is not vulnerable in Ruby since it does not use version which includes JSON into stdlib. This issue affects the version of JSON(embedded in pcs) as shipped with Red Hat Gluster Storage 3. However, the vulnerable method calls are currently not used by the…

Workaround published by Red Hat
To mitigate this vulnerability, do not supply untrusted user input and/or untrusted strings to the following method calls or utilize code libraries which do so: ``` JSON(user_input) JSON[user_input, nil] JSON.parse(user_input, nil) JSON::Parser.new(user_input).parse ``` Also note that JSON.load() should never be given input from unknown sources.
Source: Red Hat security advisory for CVE-2020-10663 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8ruby:2.5-8040020200923213910.522a0ee4RHSA-2021:2587
Red Hat Enterprise Linux 8ruby:2.6-8040020210430142949.522a0ee4RHSA-2021:2588
Red Hat Enterprise Linux 8pcs-0:0.10.4-6.el8_2.1RHSA-2020:2462
Red Hat Enterprise Linux 8.0 Update Services for SAP Solutionspcs-0:0.10.1-4.el8_0.5RHSA-2020:2473
Red Hat Enterprise Linux 8.1 Extended Update Supportpcs-0:0.10.2-4.el8_1.1RHSA-2020:2670
Red Hat Enterprise Linux 8.1 Update Services for SAP Solutionsruby:2.6-8010020220201152941.c27ad7f8RHSA-2022:0581
Red Hat Enterprise Linux 8.2 Extended Update Supportruby:2.6-8020020220201131207.4cda2c84RHSA-2022:0582
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby25-ruby-0:2.5.9-9.el7RHSA-2021:2104

Frequently Asked Questions

The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.
O3 Security · Impact-Aware SCA

Is CVE-2020-10663 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2020-10663: json — Fixed in 2.3.0