CVE-2013-0269 — json
CVE-2013-0269 is a Improper Input Validation vulnerability in json. EPSS puts its 30-day exploitation probability at 13.9% (97th percentile). A fix is available for json — see the affected versions and patch details below.
JSON gem has Improper Input Validation vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
json💎json💎jsonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | json | all versions | 1.5.5bundle update json --conservative |
| 💎RubyGems | json | ≥ 1.6.0&&< 1.6.8 | 1.6.8bundle update json --conservative |
| 💎RubyGems | json | ≥ 1.7.0&&< 1.7.7 | 1.7.7bundle update json --conservative |
Affected Products
json gemrubygemsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for json, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update json to 1.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-0269 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Satellite tools ship RubyGem Json 1.4.6 which is earlier than affected 1.5.5 version however, this version of RubyGem is not affected to the flaw. We may update RubyGem in a future release.
| Product | Fixed in | Advisory |
|---|---|---|
| Fuse ESB Enterprise 7.1.0 | see advisory | RHSA-2013:1028 |
| Red Hat JBoss Fuse 6.0 | see advisory | RHSA-2013:1185 |
| Red Hat JBoss SOA Platform 5.3 | see advisory | RHSA-2013:1147 |
| Red Hat Subscription Asset Manager 1.2 | candlepin-0:0.7.24-1.el6_3 | RHSA-2013:0686 |
| RHEL 6 Version of OpenShift Enterprise | ruby193-ruby-0:1.9.3.327-28.el6 | RHSA-2013:0701 |
Frequently Asked Questions
Is CVE-2013-0269 in your dependencies?
Find it across RubyGems, including transitive dependencies.