CVE-2026-30827 is a high-severity (CVSS 7.5) CWE-770 vulnerability in express-rate-limit. A fix is available for express-rate-limit — see the affected versions and patch details below.
express-rate-limit: IPv4-mapped IPv6 addresses bypass per-client rate limiting (all IPv4 clients share one bucket on dual-stack servers)
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-30827.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
express-rate-limitnpmDescription
Summary
The default keyGenerator in express-rate-limit applies IPv6 subnet masking (/56 by default) to all addresses that net.isIPv6() returns true for. This includes IPv4-mapped IPv6 addresses (::ffff:x.x.x.x), which Node.js returns as request.ip on dual-stack servers.
Because the first 80 bits of all IPv4-mapped addresses are zero, a /56 (or any /32 to /80) subnet mask produces the same network key (::/56) for every IPv4 client. This collapses all IPv4 traffic into a single rate-limit bucket: one client exhausting the limit causes HTTP 429 for all other IPv4 clients.
Details
Root Cause
In source/ip-key-generator.ts:
export function ipKeyGenerator(ip: string, ipv6Subnet: number | false = 56) {
if (ipv6Subnet && isIPv6(ip)) {
return `${new Address6(`${ip}/${ipv6Subnet}`).startAddress().correctForm()}/${ipv6Subnet}`
}
return ip
}
net.isIPv6('::ffff:192.168.1.1') returns true, so IPv4-mapped addresses enter the subnet masking path. With a /56 prefix, the start address for any ::ffff:x.x.x.x is ::, producing the key ::/56.
Proof of Concept
const { isIPv6 } = require('net');
const { Address6 } = require('ip-address');
function ipKeyGenerator(ip, ipv6Subnet = 56) {
if (ipv6Subnet && isIPv6(ip)) {
return `${new Address6(`${ip}/${ipv6Subnet}`).startAddress().correctForm()}/${ipv6Subnet}`;
}
return ip;
}
console.log(ipKeyGenerator('::ffff:192.168.1.1', 56)); // ::/56
console.log(ipKeyGenerator('::ffff:10.0.0.1', 56)); // ::/56
console.log(ipKeyGenerator('::ffff:8.8.8.8', 56)); // ::/56
// ALL produce '::/56' — same bucket
End-to-End Validation
On a dual-stack Express server (app.listen(port, '::')), tested with Express 5.2.1:
request.ipfor IPv4 clients is::ffff:127.0.0.1- Rate limit key resolves to
::/56 - After
limitrequests from any IPv4 client, all other IPv4 clients receive 429
When This Occurs
- Node.js dual-stack servers (default on Linux when listening on
::) - Any environment where
request.ipcontains IPv4-mapped IPv6 addresses - Only affects the default
keyGenerator(custom key generators are not affected)
Impact
- Denial of Service: A single client can block all IPv4 traffic by exhausting the shared rate limit
- Affects default configuration: No special options needed to trigger this
Affected Versions
All versions of express-rate-limit between v8.0.0 and v8.2.1.
Fix
This issue was fixed in commit 14e53888cdfd1b9798faf5b634c4206409e27fc4. This fix has been included in release v8.3.0, and backported to all affected minor versions in the form of releases v8.2.2, v8.1.1, and v8.0.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | express-rate-limit | ≥ 8.2.0&&< 8.2.2 | 8.2.2npm install express-rate-limit@8.2.2 |
| 📦npm | express-rate-limit | ≥ 8.1.0&&< 8.1.1 | 8.1.1npm install express-rate-limit@8.1.1 |
| 📦npm | express-rate-limit | ≥ 8.0.0&&< 8.0.2 | 8.0.2npm install express-rate-limit@8.0.2 |
Affected Products
express-rate-limitexpress-rate-limit_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for express-rate-limit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update express-rate-limit to 8.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-30827 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Restrict network access to applications utilizing the express-rate-limit middleware to trusted clients or networks. Implementing firewall rules or network access controls can prevent untrusted actors from exploiting the shared rate-limit bucket vulnerability affecting IPv4-mapped IPv6 addresses on dual-stack servers.Source: Red Hat security advisory for CVE-2026-30827 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-tech-preview/mcp-server-rhel9:1774268173 | RHSA-2026:6309 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-tech-preview/mcp-server-rhel9:1774268173 | RHSA-2026:6404 |
| Red Hat OpenShift Dev Spaces 3.28 | devspaces/openvsx-rhel9:1779528224 | RHSA-2026:21772 |
Frequently Asked Questions
Is CVE-2026-30827 in your dependencies?
Find it across npm, including transitive dependencies.