CVE-2026-25484 — commerce
Fix: craftcms/commerce@7e1dedfCVE-2026-25484 is a Cross-site Scripting (XSS) vulnerability in craftcms/commerce. A fix is available for craftcms/commerce — see the affected versions and patch details below.
Craft Commerce has Stored XSS in Product Type Name
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-25484.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
craftcms/commerce🐘craftcms/commerceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Stored XSS via Product Type names. The name is not sanitized when displayed in user permissions settings.
The vulnerable input (source) is in Commerce (Product Type settings), but the sink is in CMS user permissions settings. Reporting to Commerce GHSA since the input originates here.
Users are recommended to update to the patched 5.5.2 release to mitigate the issue.
Proof of Concept
Required Permissions (Attacker)
- Admin access (to edit Commerce settings)
Steps to Reproduce
- Log in as attacker with admin permissions.
- Go to Commerce -> Settings -> Product Types (
/admin/commerce/settings/producttypes). - Create a new Product Type.
- Set Name to:
<img src=x onerror="alert('XSS-ProductType')" hidden>
- Save the Product Type.
- Go to Users -> Edit any user -> Click on Permissions tab (
/admin/users/{UserID}/permissions). - Alert fires instantly (when the Product Type checkbox renders).
Resources
https://github.com/craftcms/commerce/commit/7e1dedf06038c8e70dce0187b7048d4ab8ffb75c
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | craftcms/commerce | ≥ 5.0.0&&< 5.5.2 | 5.5.2composer require craftcms/commerce:^5.5.2 |
| 🐘Packagist | craftcms/commerce | ≥ 4.0.0-RC1&&< 4.10.1 | 4.10.1composer require craftcms/commerce:^4.10.1 |
Affected Products
craft commercecraftcmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for craftcms/commerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update craftcms/commerce to 5.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-25484 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-25484 in your dependencies?
Find it across Packagist, including transitive dependencies.