CVE-2025-64527 — envoy
MEDIUMCVE-2025-64527 is a medium-severity (CVSS 6.5) NULL Pointer Dereference vulnerability in github.com/envoyproxy/envoy. A fix is available for github.com/envoyproxy/envoy — see the affected versions and patch details below.
Envoy crashes when JWT authentication is configured with the remote JWKS fetching
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-64527.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoy🐹github.com/envoyproxy/envoyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Envoy crashes when JWT authentication is configured with the remote JWKS fetching, allow_missing_or_failed is enabled, multiple JWT tokens are present in the request headers and the JWKS fetch fails.
Details
This is caused by a re-entry bug in the JwksFetcherImpl. When the first token's JWKS fetch fails, onJwksError() callback triggers processing of the second token, which calls fetch() again on the same fetcher object.
The original callback's reset() then clears the second fetch's state (receiver_ and request_) which causes a crash when the async HTTP response arrives.
PoC
allow_missing_or_failedorallow_missingis enabled- The client send 2 Authorization headers
- the remote JWKS fetching failed
- There will be crash
Impact
DoS and Crash
Mitigation
- Disable the
allow_missing_or_failedorallow_missing
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.36.0&&< 1.36.3 | 1.36.3go get github.com/envoyproxy/envoy@v1.36.3 |
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.35.0&&< 1.35.7 | 1.35.7go get github.com/envoyproxy/envoy@v1.35.7 |
| 🐹Go | github.com/envoyproxy/envoy | ≥ 1.34.0&&< 1.34.11 | 1.34.11go get github.com/envoyproxy/envoy@v1.34.11 |
| 🐹Go | github.com/envoyproxy/envoy | all versions | 1.33.13go get github.com/envoyproxy/envoy@v1.33.13 |
Affected Products
envoyenvoyproxyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/envoyproxy/envoy, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/envoyproxy/envoy to 1.36.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-64527 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-64527 in your dependencies?
Find it across Go, including transitive dependencies.