NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-62783 — inventorygui

MEDIUMFix: Phoenix616/InventoryGui@27a52ef

CVE-2025-62783 is a medium-severity (CVSS 5) CWE-837 vulnerability in de.themoep:inventorygui. A fix is available for de.themoep:inventorygui — see the affected versions and patch details below.

InventoryGui affected by item duplication in GUIs which use GuiStorageElement

Also known asGHSA-598q-jw82-5w66
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-62783.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.0%0.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕de.themoep:inventorygui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions 1.6.1-SNAPSHOT and earlier contain a vulnerability where any plugin using the `GuiStorageElement can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.2-SNAPSHOT.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavende.themoep:inventoryguiall versions1.6.2-SNAPSHOTde.themoep:inventorygui:1.6.2-SNAPSHOT

Affected Products

1 product · 1 configurations
Application
inventoryguiphoenix616
< 1.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for de.themoep:inventorygui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update de.themoep:inventorygui to 1.6.2-SNAPSHOT or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-62783 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

InventoryGui is a library for creating chest GUIs for Bukkit/Spigot plugins. Versions 1.6.1-SNAPSHOT and earlier contain a vulnerability where any plugin using the `GuiStorageElement can allow item duplication when the experimental Bundle item feature is enabled on the server. The vulnerability is resolved in version 1.6.2-SNAPSHOT.
O3 Security · Impact-Aware SCA

Is CVE-2025-62783 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-62783: inventorygui — Fix Available