NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

InventoryGui affected by item duplication in GUIs which use GuiStorageElementGHSA-598q-jw82-5w66

MEDIUMFix: Phoenix616/InventoryGui@27a52ef

GHSA-598q-jw82-5w66 is a medium-severity (CVSS 5) CWE-837 vulnerability in de.themoep:inventorygui. A fix is available for de.themoep:inventorygui — see the affected versions and patch details below.

Also known asCVE-2025-62783
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-598q-jw82-5w66.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs17th percentile — riskier than 17% of all scored CVEsHighest risk
0.00%0.25%0.50%0.75%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕de.themoep:inventorygui

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Any plugin using the GuiStorageElement is impacted.

Patches

Patched with https://github.com/Phoenix616/InventoryGui/commit/27a52ef6d934a1c232e110e0010e4aa810c27029 ("backported" to 1.6.1-SNAPSHOT) Update to 1.6.2-SNAPSHOT to guarantee that it's included!

Workarounds

Don't use the GuiStorageElement in GUIs.

References

Original issue: https://github.com/Phoenix616/InventoryGui/issues/48

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavende.themoep:inventoryguiall versions1.6.2-SNAPSHOTde.themoep:inventorygui:1.6.2-SNAPSHOT

Affected Products

1 product · 1 configurations
Application
inventoryguiphoenix616
< 1.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for de.themoep:inventorygui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update de.themoep:inventorygui to 1.6.2-SNAPSHOT or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-598q-jw82-5w66 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact Any plugin using the `GuiStorageElement` is impacted. ### Patches Patched with https://github.com/Phoenix616/InventoryGui/commit/27a52ef6d934a1c232e110e0010e4aa810c27029 ("backported" to 1.6.1-SNAPSHOT) Update to 1.6.2-SNAPSHOT to guarantee that it's included! ### Workarounds Don't use the `GuiStorageElement` in GUIs. ### References Original issue: https://github.com/Phoenix616/InventoryGui/issues/48
O3 Security · Impact-Aware SCA

Is GHSA-598q-jw82-5w66 in your dependencies?

Find it across Maven, including transitive dependencies.

InventoryGui affected by item duplication in GUIs which…