NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2025-54988 — tika-parser-pdf-module

HIGHFix: apache/tika#2291

CVE-2025-54988 is a high-severity (CVSS 8.4) XML External Entity (XXE) vulnerability in org.apache.tika:tika-parser-pdf-module. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tika:tika-parser-pdf-module — see the affected versions and patch details below.

Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA

Also known asGHSA-p72g-pv48-7w9x
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-54988.

EPSS Exploitation Probability

via FIRST.org ↗
47.9%probability of exploitation in next 30 days
High Risk0.00%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%20.8%41.6%62.3%0.0%47.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.tika:tika-parser-pdf-module☕org.apache.tika:tika-parsers

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard.

Users are recommended to upgrade to version 3.2.2, which fixes this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tika:tika-parser-pdf-module≥ 1.13&&< 3.2.23.2.2org.apache.tika:tika-parser-pdf-module:3.2.2
☕Mavenorg.apache.tika:tika-parsers≥ 1.13&&< 2.0.0-ALPHA2.0.0-ALPHAorg.apache.tika:tika-parsers:2.0.0-ALPHA

Affected Products

1 product · 1 configurations
Application
tikaapache
≥ 1.13 && < 3.2.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-parser-pdf-module, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tika:tika-parser-pdf-module to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-54988 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2025-54988

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2025-54988 -u https://target
Template
Apache Tika - XXE Injection
Severity
critical
Impact
An attacker can read sensitive server files or perform SSRF attacks against internal infrastructure.
Remediation
Upgrade to Apache Tika 3.2.2 or later.

Template by ProjectDiscovery nuclei-templates (tx1ee, s4e-io), MIT licensed. View the full template. Scan only systems you are authorised to test.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatCritical

Within Red Hat products, the tika-parser-pdf-module is exclusively used for testing purposes at build time, it is not included in any shipped releases of Camel Spring Boot or JBoss EAP.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2025-54988 (CC BY 4.0)

Frequently Asked Questions

Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection via a crafted XFA file inside of a PDF. An attacker may be able to read sensitive data or trigger malicious requests to internal resources or third-party servers. Note that the tika-parser-pdf-module is used as a dependency in several Tika packages including at least: tika-parsers-standard-modules, tika-parsers-standard-package, tika-app, tika-grpc and tika-server-standard. Users are recommended to upgrade to versio
O3 Security · Impact-Aware SCA

Is CVE-2025-54988 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-54988: tika-parser-pdf XXE — Fixed in 3.2.2