NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2018-1339 — tika-parsers

MEDIUMFix: apache/tika@1b6ca36

CVE-2018-1339 is a medium-severity (CVSS 5.5) CWE-835 vulnerability in org.apache.tika:tika-parsers. A fix is available for org.apache.tika:tika-parsers — see the affected versions and patch details below.

org.apache.tika:tika-parsers has an Infinite Loop vulnerability

Also known asGHSA-p699-3wgc-7h72
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk-0.05%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
1.97%3.02%4.06%5.10%4.5%2.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.tika:tika-parsers

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Versions of the package org.apache.tika:tika-parsers before version 1.18 are vulnerable to Denial of Service (DoS) via a carefully crafted (or fuzzed) file that can trigger an infinite loop via the ChmParser.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tika:tika-parsersall versions1.18org.apache.tika:tika-parsers:1.18

Affected Products

1 product · 1 configurations
Application
tikaapache
< 1.18
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tika:tika-parsers, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tika:tika-parsers to 1.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1339 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue affects the versions of tika which is embedded in the nutch package as shipped with Red Hat Satellite 5. The tika server is not exposed, as such exploitation is difficult, Red Hat Product Security has rated this issue as having security impact of Low. A future update may address this issue. For additional…

ProductFixed inAdvisory
Red Hat JBoss Fuse 7camel-tikaRHSA-2018:2669

Frequently Asked Questions

Versions of the package `org.apache.tika:tika-parsers` before version 1.18 are vulnerable to Denial of Service (DoS) via a carefully crafted (or fuzzed) file that can trigger an infinite loop via the ChmParser.
O3 Security · Impact-Aware SCA

Is CVE-2018-1339 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1339: tika-parsers DoS — Fixed in 1.18