CVE-2025-49575 is a medium-severity (CVSS 6.5) Cross-site Scripting (XSS) vulnerability in starcitizentools/citizen-skin. A fix is available for starcitizentools/citizen-skin — see the affected versions and patch details below.
Citizen allows stored XSS in Command Palette tip messages
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-49575.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
starcitizentools/citizen-skinReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Multiple system messages are inserted into the CommandPaletteFooter as raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM.
Details
The messages are retrieved using the plain() output mode: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L61-L66
currentTip is set to one of these messages: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L69
currentTip is inserted as raw HTML (vue/no-v-html should not be ignored here): https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/072e4365e9084e4b153eac62d3666566c06f5a49/resources/skins.citizen.commandPalette/components/CommandPaletteFooter.vue#L3-L4
PoC
- Edit
citizen-command-palette-tip-commands,citizen-command-palette-tip-users,citizen-command-palette-tip-namespaceandcitizen-command-palette-tip-templatesto<img src="" onerror="alert(1)">(script tags don't work here due to the way the HTML is inserted) - Open the command palette
Impact
This impacts wikis where a group has the editinterface but not the editsitejs user right.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | starcitizentools/citizen-skin | ≥ 2.4.2&&< 3.3.1 | 3.3.1composer require starcitizentools/citizen-skin:^3.3.1 |
Affected Products
citizenstarcitizen.toolsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for starcitizentools/citizen-skin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update starcitizentools/citizen-skin to 3.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-49575 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2025-49575 in your dependencies?
Find it across Packagist, including transitive dependencies.