`\n4. Save your sett"}},{"@type":"Question","name":"How severe is CVE-2024-47536?","acceptedAnswer":{"@type":"Answer","text":"No CVSS score has been assigned to CVE-2024-47536 yet. Review the advisory details and affected package list to assess your exposure."}},{"@type":"Question","name":"Which packages are affected by CVE-2024-47536?","acceptedAnswer":{"@type":"Answer","text":"CVE-2024-47536 affects the following packages: starcitizentools/citizen-skin (Packagist). Ecosystems affected: Packagist."}},{"@type":"Question","name":"How do I fix CVE-2024-47536?","acceptedAnswer":{"@type":"Answer","text":"Update starcitizentools/citizen-skin to 2.31.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47536 is resolved across your whole dependency graph."}},{"@type":"Question","name":"How do I detect CVE-2024-47536 in my Packagist dependencies?","acceptedAnswer":{"@type":"Answer","text":"Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for starcitizentools/citizen-skin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version."}},{"@type":"Question","name":"How do I mitigate CVE-2024-47536 if there is no patch (or I can't update yet)?","acceptedAnswer":{"@type":"Answer","text":"Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page."}},{"@type":"Question","name":"Is CVE-2024-47536 actively exploited in the wild?","acceptedAnswer":{"@type":"Answer","text":"No public exploit code has been indexed for CVE-2024-47536 yet. This does not mean the vulnerability cannot be exploited — absence of public exploits does not imply safety. Apply the recommended fix and use O3 Security to monitor your exposure."}},{"@type":"Question","name":"What is the EPSS score for CVE-2024-47536?","acceptedAnswer":{"@type":"Answer","text":"CVE-2024-47536 has an EPSS (Exploit Prediction Scoring System) score of 0.5%, placing it in the 40th percentile of all CVEs. EPSS is maintained by FIRST.org and estimates the probability that a vulnerability will be exploited in the wild within the next 30 days. This score indicates relatively lower exploitation probability, though the CVSS severity should still guide your patching priority."}},{"@type":"Question","name":"What type of vulnerability is CVE-2024-47536?","acceptedAnswer":{"@type":"Answer","text":"CVE-2024-47536 is classified as Cross-site Scripting (XSS) (CWE-79), CWE-80 (CWE-80). These weakness types describe the underlying flaw category, which helps determine the potential impact and the right class of mitigation. This is a high-impact weakness class that often enables remote code execution or data exposure."}},{"@type":"Question","name":"When was CVE-2024-47536 published, and has it been updated?","acceptedAnswer":{"@type":"Answer","text":"CVE-2024-47536 was published on September 30, 2024 and was last updated on October 28, 2026. Advisory data evolves as severity scores, affected ranges, and exploit intelligence are revised — always check the latest version of the advisory before acting."}}]}
NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2024-47536 — citizen-skin

Fix: StarCitizenTools/mediawiki-skins-Citizen@717d16a

CVE-2024-47536 is a Cross-site Scripting (XSS) vulnerability in starcitizentools/citizen-skin. A fix is available for starcitizentools/citizen-skin — see the affected versions and patch details below.

starcitizentools/citizen-skin vulnerable to stored, self-XSS in the "real name" field

Also known asGHSA-62r2-gcxr-426x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-47536.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.43%0.87%1.30%0.8%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘starcitizentools/citizen-skin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A user with the editmyprivateinfo right or who can otherwise change their name can XSS themselves by setting their "real name" to an XSS payload.

Details

Here's the offending line: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/d45c3d69f30863f622f16eb40dd41d3ca943454a/includes/Components/CitizenComponentUserInfo.php#L137

This was introduced in 717d16af35b10dab04d434aefddbf991fc8c168c

PoC

  1. Login
  2. Go to Special:Preferences
  3. Set the real name field to a string like <script>alert("Admin with a propensity for self-XSSes")</script>
  4. Save your settings and use Citizen if it's not being used already

Impact

Any user who can change their name (whether it's through the editmyprivateinfo right or through other means) can add XSS payloads that trigger for themselves only.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagiststarcitizentools/citizen-skin≥ 2.6.3&&< 2.31.02.31.0composer require starcitizentools/citizen-skin:^2.31.0

Affected Products

1 product · 1 configurations
Application
citizenstarcitizen.tools
< 2.31.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for starcitizentools/citizen-skin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update starcitizentools/citizen-skin to 2.31.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-47536 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary A user with the `editmyprivateinfo` right or who can otherwise change their name can XSS themselves by setting their "real name" to an XSS payload. ### Details Here's the offending line: https://github.com/StarCitizenTools/mediawiki-skins-Citizen/blob/d45c3d69f30863f622f16eb40dd41d3ca943454a/includes/Components/CitizenComponentUserInfo.php#L137 This was introduced in 717d16af35b10dab04d434aefddbf991fc8c168c ### PoC 1. Login 2. Go to Special:Preferences 3. Set the real name field to a string like `<script>alert("Admin with a propensity for self-XSSes")</script>` 4. Save your sett
O3 Security · Impact-Aware SCA

Is CVE-2024-47536 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-47536: citizen-skin XSS — Fixed in 2.31.0