# CVE-2025-48371: openfga — Fixed in 1.8.13

🐹 Go

Not in CISA KEV

# CVE-2025-48371 — openfga

[Fix: openfga/openfga@e5960d4](https://github.com/openfga/openfga/commit/e5960d4eba92b723de8ff3a5346a07f50c1379ca)

CVE-2025-48371 is a CWE-285 vulnerability in github.com/openfga/openfga. A fix is available for github.com/openfga/openfga — see the affected versions and patch details below.

OpenFGA Authorization Bypass

Also known as[GHSA-c72g-53hw-82q7](/vulnerability/GHSA-c72g-53hw-82q7)GO-2025-3707

Published

May 22, 2025

Updated

Oct 28, 2026

Affected

1 pkg

Patched

1 / 1

Exploits

None indexed

Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

## Exploitation Status

### No confirmed exploitation observed yet

-   CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48371.

## EPSS Exploitation Probability

[via FIRST.org ↗](https://www.first.org/epss/)

0.5%probability of exploitation in next 30 days

Lower Risk0.00%

Lower risk than most CVEs43th percentile — riskier than 43% of all scored CVEsHighest risk

0.00%0.33%0.67%1.00%0.1%0.4%0.5%0.5%0.5%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from [FIRST.org EPSS](https://www.first.org/epss/).

## Real-World Exposure

1 pkg affected

🐹`github.com/openfga/openfga`

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

## Description

#### Overview

OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.

#### Am I Affected?

If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability:

-   Calling Check API or ListObjects with an [authorization model](https://openfga.dev/docs/concepts#what-is-an-authorization-model) that has a relationship directly assignable by both [type bound public access](https://openfga.dev/docs/concepts#what-is-type-bound-public-access) and [userset](https://openfga.dev/docs/modeling/building-blocks/usersets), and
-   There are check or list object queries with [contextual tuples](https://openfga.dev/docs/interacting/contextual-tuples) for the relationship that can be directly assignable by both [type bound public access](https://openfga.dev/docs/concepts#what-is-type-bound-public-access) and [userset](https://openfga.dev/docs/modeling/building-blocks/usersets), and
-   Those contextual tuples’s user field is an userset, and
-   Type bound public access tuples are not assigned to the relationship

#### Fix

Upgrade to v1.8.13. This upgrade is backwards compatible.

#### Acknowledgments

OpenFGA would like to thank @udyvish for discovering this vulnerability.

## Affected Packages

1 total 1 fixed

Ecosystem

Package

Vulnerable range

Fix

🐹Go

`github.com/openfga/openfga` 

≥ 1.8.0&&< 1.8.13

1.8.13`go get github.com/openfga/openfga@v1.8.13`

## Affected Products

2 products · 2 configurations

Application

`helm charts`openfga

≥ 0.2.16 && < 0.2.32

range

Application

`openfga`openfga

≥ 1.8.0 && < 1.8.13

range

## Detection & mitigation playbook

Open-source dependency

1.  ### Detect
    
    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openfga/openfga, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
    
2.  ### Fix
    
    Update github.com/openfga/openfga to 1.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48371 is resolved across your whole dependency graph.
    
3.  ### Workarounds
    
    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
    

## Frequently Asked Questions

\### Overview OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. ### Am I Affected? If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability: - Calling Check API or ListObjects with an \[authorization model\](https://openfga.dev/docs/concepts#what-is-an-authorization-model) that has a relationship directly assignable by both \[type bound public access\](https:/

O3 Security · Impact-Aware SCA

### Is CVE-2025-48371 in your dependencies?

Find it across Go, including transitive dependencies.

[Scan my dependencies](/book-demo) [How O3 SCA works](/impact-aware-sca)