CVE-2025-46701 is a high-severity (CVSS 7.3) CWE-178 vulnerability in org.apache.tomcat:tomcat-catalina. A fix is available for org.apache.tomcat:tomcat-catalina — see the affected versions and patch details below.
Apache Tomcat: Security constraint bypass for CGI scripts
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-46701.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 9.0.0.M1&&< 9.0.105 | 9.0.105org.apache.tomcat:tomcat-catalina:9.0.105 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1&&< 10.1.41 | 10.1.41org.apache.tomcat:tomcat-catalina:10.1.41 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 11.0.0-M1&&< 11.0.7 | 11.0.7org.apache.tomcat:tomcat-catalina:11.0.7 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 9.0.0.M1&&< 9.0.105 | 9.0.105org.apache.tomcat.embed:tomcat-embed-core:9.0.105 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1&&< 10.1.41 | 10.1.41org.apache.tomcat.embed:tomcat-embed-core:10.1.41 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M1&&< 11.0.7 | 11.0.7org.apache.tomcat.embed:tomcat-embed-core:11.0.7 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-catalina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-catalina to 9.0.105 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-46701 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated Moderate rather than Important due to several limiting technical factors that reduce its overall impact and exploitability. Firstly, the flaw only manifests on case-insensitive file systems (e.g., Windows NTFS or macOS HFS+), which are less common in production-grade Tomcat deployments,…
Mitigation is either unavailable or does not meet Red Hat Product Security standards for usability, deployment, applicability, or stability.Source: Red Hat security advisory for CVE-2025-46701 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.110-2.el10_2 | RHSA-2026:18536 |
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.49-1.el10 | RHSA-2026:18537 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.120-1.el10_0 | RHSA-2026:67163 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.120-1.el8_10 | RHSA-2026:68677 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.120-1.el8_8 | RHSA-2026:68680 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.110-2.el9_8 | RHSA-2026:18916 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_2 | RHSA-2026:68678 |
| Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_4 | RHSA-2026:68679 |
Frequently Asked Questions
Is CVE-2025-46701 in your dependencies?
Find it across Maven, including transitive dependencies.