CVE-2025-46572 — passport-wsfed-saml2
Fix: auth0/passport-wsfed-saml2@e5cf3ccCVE-2025-46572 is a Improper Authentication vulnerability in passport-wsfed-saml2. A fix is available for passport-wsfed-saml2 — see the affected versions and patch details below.
passport-wsfed-saml2 Has SAML Authentication Bypass via Signature Wrapping
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-46572.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
passport-wsfed-saml2npmDescription
Overview
This vulnerability allows an attacker to impersonate any user during SAML authentication by crafting a SAMLResponse. This can be done by using a valid SAML object that was signed by the configured IdP.
Am I Affected?
You are affected by this SAML Signature Wrapping vulnerability if you are using passport-wsfed-saml2 version 4.6.3 or below, specifically under the following conditions:
- The service provider is using
passport-wsfed-saml2, - A valid SAML document signed by the Identity Provider can be obtained.
Fix
Upgrade to v4.6.4 or greater.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | passport-wsfed-saml2 | ≥ 3.0.5&&< 4.6.4 | 4.6.4npm install passport-wsfed-saml2@4.6.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passport-wsfed-saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update passport-wsfed-saml2 to 4.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-46572 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2025-46572 in your dependencies?
Find it across npm, including transitive dependencies.