NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-23505 — passport-wsfed-saml2

MEDIUMFix: auth0/passport-wsfed-saml2#179

CVE-2022-23505 is a medium-severity (CVSS 5.3) Improper Authentication vulnerability in passport-wsfed-saml2. A fix is available for passport-wsfed-saml2 — see the affected versions and patch details below.

Authentication Bypass for passport-wsfed-saml2

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.43%0.87%1.30%0.4%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
passport-wsfed-saml2npm
1Kdownloads / week

Description

Overview

A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered.

Am I affected?

You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3. SAML2 protocol is not affected.

How do I fix it?

Upgrade the library to version 4.6.3.

Will the fix impact my users?

No, the fix will not impact your users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpassport-wsfed-saml2all versions4.6.3npm install passport-wsfed-saml2@4.6.3

Affected Products

1 product · 1 configurations
Application
passport-wsfed-saml2auth0
≤ 4.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passport-wsfed-saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passport-wsfed-saml2 to 4.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23505 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

# Overview A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. # Am I affected? You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3. SAML2 protocol is not affected. # How do I fix it? Upgrade the library to version 4.6.3. # Wil
O3 Security · Impact-Aware SCA

Is CVE-2022-23505 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-23505: passport-wsfed-saml2 — Fixed in 4.6.3