NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2017-16897 — passport-wsfed-saml2

HIGHFix: auth0/passport-wsfed-saml2@520b9fc

CVE-2017-16897 is a high-severity (CVSS 8.1) CWE-290 vulnerability in passport-wsfed-saml2. A fix is available for passport-wsfed-saml2 — see the affected versions and patch details below.

passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token

Also known asGHSA-77fw-rf4v-vfp9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.63%1.25%1.88%0.4%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
passport-wsfed-saml2npm
5Kdownloads / week

Description

Information

Please note that this is not a new disclosure, and is previously reported in our SECURITY-NOTICE.md which we removed in favor of github advisory.

Overview

This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider:

  • signs SAML response and signs assertion

  • does not sign SAML response and signs assertion

Am I affected?

You may be affected if you use SAML2 protocol with passport-wsfed-saml2 versions below 3.0.5 and your SAML identity Provider:

  1. signs SAML response and signs assertion; or
  2. does not sign SAML response and signs assertion

How do I fix it?

You may fix this vulnerability by upgrading your library to version 3.0.5 or above.

Will the fix impact my users?

This fix patches the library that your application runs, but will not impact your users, their current state, or any existing sessions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpassport-wsfed-saml2all versions3.0.5npm install passport-wsfed-saml2@3.0.5

Affected Products

1 product · 1 configurations
Application
passport-wsfed-saml2auth0
< 3.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passport-wsfed-saml2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passport-wsfed-saml2 to 3.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16897 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

## Information Please note that this is not a new disclosure, and is previously reported in our [SECURITY-NOTICE.md](https://github.com/auth0/passport-wsfed-saml2/commit/520b9fc0bb4249ce83bec47e30153419f086ab70 ) which we removed in favor of github advisory. # Overview This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider: - signs SAML response and signs assertion - does not sign SAML response and signs assertion # Am I affected? You may be affected if you use SAML2 protocol with passport-wsfed-saml2 ver
O3 Security · Impact-Aware SCA

Is CVE-2017-16897 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2017-16897: passport-wsfed-saml2 — Fixed in 3.0.5