CVE-2024-55877 is a critical-severity (CVSS 9.9) CWE-96 vulnerability in org.xwiki.platform:xwiki-platform-help-ui. A fix is available for org.xwiki.platform:xwiki-platform-help-ui — see the affected versions and patch details below.
XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55877.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-help-ui☕org.xwiki.platform:xwiki-platform-help-ui☕org.xwiki.platform:xwiki-platform-help-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Any user with an account can perform arbitrary remote code execution by adding instances of XWiki.WikiMacroClass to any page. This compromises the confidentiality, integrity and availability of the whole XWiki installation.
To reproduce on a instance, as a connected user without script nor programming rights, go to your user profile and add an object of type XWiki.WikiMacroClass. Set "Macro Id", "Macro Name" and "Macro Code" to any value, "Macro Visibility" to Current User and "Macro Description" to {{async}}{{groovy}}println("Hello from User macro!"){{/groovy}}{{/async}}.
Save the page, then go to <host>/xwiki/bin/view/XWiki/XWikiSyntaxMacrosList.
If the description of your new macro reads "Hello from User macro!", then your instance is vulnerable.
Patches
This vulnerability has been fixed in XWiki 15.10.11, 16.4.1 and 16.5.0.
Workarounds
It is possible to manually apply this patch to the page XWiki.XWikiSyntaxMacrosList.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-help-ui | ≥ 9.7-rc-1&&< 15.10.11 | 15.10.11org.xwiki.platform:xwiki-platform-help-ui:15.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-help-ui | ≥ 16.0.0-rc-1&&< 16.4.1 | 16.4.1org.xwiki.platform:xwiki-platform-help-ui:16.4.1 |
| ☕Maven | org.xwiki.platform:xwiki-platform-help-ui | ≥ 16.5.0-rc-1&&< 16.5.0 | 16.5.0org.xwiki.platform:xwiki-platform-help-ui:16.5.0 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-help-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-help-ui to 15.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-55877 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2024-55877 in your dependencies?
Find it across Maven, including transitive dependencies.