CVE-2023-35166 is a critical-severity (CVSS 9.9) CWE-863 vulnerability in org.xwiki.platform:xwiki-platform-help-ui. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-help-ui — see the affected versions and patch details below.
Privilege escalation (PR) from account through TipsPanel
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-35166.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-help-ui☕org.xwiki.platform:xwiki-platform-help-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible to execute any wiki content with the right of the TipsPanel author by creating a tip UI extension.
To reproduce:
- Add an object of type UIExtensionClass
- Set "Extension Point ID" to org.xwiki.platform.help.tipsPanel
- Set "Extension ID" to org.xwiki.platform.user.test (needs to be unique but otherwise doesn't matter)
- Set "Extension Parameters" to
tip={{async async="true" cached="false" context="doc.reference"}}{{groovy}}println("Hello " + "from groovy!"){{/groovy}}{{/async}} - Set "Extension Scope" to "Current User".
- Click "Save & View"
- Open the "Help.TipsPanel" document at <xwiki-host>/xwiki/bin/view/Help/TipsPanel where <xwiki-host> is the URL of your XWiki installation and press refresh repeatedly.
The groovy macro is executed, after the fix you get an error instead.
Patches
This has been patched in XWiki 15.1-rc-1 and 14.10.5.
Workarounds
There are no known workarounds for it.
References
- https://jira.xwiki.org/browse/XWIKI-20281
- https://github.com/xwiki/xwiki-platform/commit/98208c5bb1e8cdf3ff1ac35d8b3d1cb3c28b3263#diff-4e3467d2ef3871a68b2f910e67cf84531751b32e0126321be83c0f1ed5d90b29L176-R178
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira XWiki.org
- Email us at Security Mailing List
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-help-ui | ≥ 8.1-milestone-1&&< 14.10.5 | 14.10.5org.xwiki.platform:xwiki-platform-help-ui:14.10.5 |
| ☕Maven | org.xwiki.platform:xwiki-platform-help-ui | ≥ 15.0-rc-1&&< 15.1-rc-1 | 15.1-rc-1org.xwiki.platform:xwiki-platform-help-ui:15.1-rc-1 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-help-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-help-ui to 14.10.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-35166 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-35166 in your dependencies?
Find it across Maven, including transitive dependencies.