CVE-2024-37900 is a medium-severity (CVSS 6.4) CWE-96 vulnerability in org.xwiki.platform:xwiki-platform-web-war. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.xwiki.platform:xwiki-platform-web-war — see the affected versions and patch details below.
XWiki Platform vulnerable to Cross-site Scripting through attachment filename in uploader
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-37900.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-web-war☕org.xwiki.platform:xwiki-platform-web-war☕org.xwiki.platform:xwiki-platform-web-war☕org.xwiki.platform:xwiki-platform-web-warReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When uploading an attachment with a malicious filename, malicious JavaScript code could be executed. This requires a social engineering attack to get the victim into uploading a file with a malicious name. The malicious code is solely executed during the upload and affects only the user uploading the attachment. While this allows performing actions in the name of that user, it seems unlikely that a user wouldn't notice the malicious filename while uploading the attachment.
In order to reproduce, as any user, create a file named "><img src=1 onerror=alert(1)>.jpg. Then go to any page where you have edit rights and upload the file in the attachments tab. If alerts appear and display "1", then the instance is vulnerable.
Patches
This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.
Workarounds
We're not aware of any workaround except upgrading.
References
- https://jira.xwiki.org/browse/XWIKI-19611
- https://jira.xwiki.org/browse/XWIKI-21769
- https://jira.xwiki.org/browse/XWIKI-19602
- https://github.com/xwiki/xwiki-platform/commit/910a5018a50039e8b24556573dfe342f143ef949
Attribution
This vulnerability has been independently reported by Aleksey Solovev (Positive Technologies) and Georgios Roumeliotis for TwelveSec.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-web-war | ≥ 4.2-milestone-3&&< 14.10.21 | 14.10.21org.xwiki.platform:xwiki-platform-web-war:14.10.21 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-war | ≥ 15.0-rc-1&&< 15.5.5 | 15.5.5org.xwiki.platform:xwiki-platform-web-war:15.5.5 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-war | ≥ 15.6-rc-1&&< 15.10.6 | 15.10.6org.xwiki.platform:xwiki-platform-web-war:15.10.6 |
| ☕Maven | org.xwiki.platform:xwiki-platform-web-war | ≥ 16.0.0-rc-1&&< 16.0.0 | 16.0.0org.xwiki.platform:xwiki-platform-web-war:16.0.0 |
Affected Products
xwikixwikiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-web-war, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-web-war to 14.10.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-37900 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2024-37900 in your dependencies?
Find it across Maven, including transitive dependencies.