NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-55415 — voyager

MEDIUM

CVE-2024-55415 is a medium-severity (CVSS 5.7) Path Traversal vulnerability in tcg/voyager. EPSS puts its 30-day exploitation probability at 15.7% (97th percentile). The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

DevDojo Voyager vulnerable to path traversal

Also known asGHSA-j63m-2vr6-fv7m
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55415.

EPSS Exploitation Probability

via FIRST.org ↗
15.7%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.54%25.5%50.5%75.5%59.7%15.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘tcg/voyager

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

DevDojo Voyager through 1.8.0 is vulnerable to path traversal at the /admin/compass.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagisttcg/voyagerall versionsNo fix

Affected Products

1 product · 1 configurations
Application
voyagerthecontrolgroup
≤ 1.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tcg/voyager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of tcg/voyager for CVE-2024-55415. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

How to detect CVE-2024-55415

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-55415 -u https://target
Template
DevDojo Voyager <=1.8.0 - Arbitrary File Read
Severity
high
Impact
Authenticated attackers can exploit path traversal to read arbitrary files from the server, potentially exposing sensitive configuration files, credentials, and application source code.
Remediation
Update DevDojo Voyager to version 1.8.1 or later to address the path traversal vulnerability.

Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

DevDojo Voyager through 1.8.0 is vulnerable to path traversal at the /admin/compass.
O3 Security · Impact-Aware SCA

Is CVE-2024-55415 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-55415: voyager Path Traversal (Medium 5.7)