NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-55417 — voyager

MEDIUM

CVE-2024-55417 is a medium-severity (CVSS 4.3) Unrestricted File Upload vulnerability in tcg/voyager. EPSS puts its 30-day exploitation probability at 15.9% (97th percentile). The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

DevDojo Voyager Arbitrary File Write

Also known asGHSA-35p2-5vrh-m3p6
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-55417.

EPSS Exploitation Probability

via FIRST.org ↗
15.9%probability of exploitation in next 30 days
Moderate Risk+1.77%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
9.08%14.8%20.5%26.2%23.0%15.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘tcg/voyager

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

DevDojo Voyager through version 1.8.0 is vulnerable to bypassing the file type verification when an authenticated user uploads a file via /admin/media/upload. An authenticated user can upload a web shell causing arbitrary code execution on the server.

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
🐘Packagisttcg/voyagerall versionsNo fix

Affected Products

1 product · 1 configurations
Application
voyagerthecontrolgroup
≤ 1.8.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tcg/voyager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of tcg/voyager for CVE-2024-55417. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.

How to detect CVE-2024-55417

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-55417 -u https://target
Template
DevDojo Voyager <= 1.8.0 - Arbitrary File Write vulnerability
Severity
high
Impact
Authenticated attackers can bypass file type restrictions to upload PHP web shells, allowing arbitrary code execution on the server with web server privileges.
Remediation
Update DevDojo Voyager to version 1.8.1 or later to address the file upload validation bypass vulnerability.

Template by ProjectDiscovery nuclei-templates (iamnoooob, rootxharsh, pdresearch), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

DevDojo Voyager through version 1.8.0 is vulnerable to bypassing the file type verification when an authenticated user uploads a file via /admin/media/upload. An authenticated user can upload a web shell causing arbitrary code execution on the server.
O3 Security · Impact-Aware SCA

Is CVE-2024-55417 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-55417: voyager RCE (Medium 4.3)