CVE-2024-49769 is a high-severity (CVSS 7.5) CWE-772 vulnerability in waitress. A fix is available for waitress — see the affected versions and patch details below.
Waitress has a denial of service leading to high CPU usage/resource exhaustion
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49769.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
waitressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When a remote client closes the connection before waitress has had the opportunity to call getpeername() waitress won't correctly clean up the connection leading to the main thread attempting to write to a socket that no longer exists, but not removing it from the list of sockets to attempt to process. This leads to a busy-loop calling the write function.
A remote attacker could run waitress out of available sockets with very little resources required.
Patches
Waitress 3.0.1 contains fixes that remove the race condition.
Workarounds
No work-around.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | waitress | all versions | 3.0.1pip install --upgrade 'waitress==3.0.1' |
Affected Products
waitressagendalessDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for waitress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update waitress to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49769 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2024-49769 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Ironic content for Red Hat OpenShift Container Platform 4.12 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10535 |
| Ironic content for Red Hat OpenShift Container Platform 4.13 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10815 |
| Red Hat OpenShift Container Platform 4.14 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9623 |
| Red Hat OpenShift Container Platform 4.15 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10145 |
| Red Hat OpenShift Container Platform 4.16 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9618 |
| Red Hat OpenShift Container Platform 4.17 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9613 |
| Red Hat OpenStack Platform 16.2 | python-waitress-0:2.0.0-4.el8ost | RHSA-2025:0201 |
| Red Hat OpenStack Platform 17.1 for RHEL 8 | python-waitress-0:2.0.0-4.el8ost | RHSA-2025:1192 |
Frequently Asked Questions
Is CVE-2024-49769 in your dependencies?
Find it across PyPI, including transitive dependencies.