CVE-2024-49768 is a critical-severity (CVSS 9.1) CWE-367 vulnerability in waitress. A fix is available for waitress — see the affected versions and patch details below.
Waitress has request processing race condition in HTTP pipelining with invalid first request
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-49768.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
waitressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A remote client may send a request that is exactly recv_bytes (defaults to 8192) long, followed by a secondary request using HTTP pipelining.
When request lookahead is disabled (default) we won't read any more requests, and when the first request fails due to a parsing error, we simply close the connection.
However when request lookahead is enabled, it is possible to process and receive the first request, start sending the error message back to the client while we read the next request and queue it. This will allow the secondary request to be serviced by the worker thread while the connection should be closed.
Patches
Waitress 3.0.1 fixes the race condition.
Workarounds
Disable channel_request_lookahead, this is set to 0 by default disabling this feature. For this vulnerability this value is required to be changed from the default.
For more information
If you have any questions or comments about this advisory:
- Open an issue in https://github.com/Pylons/waitress/issues (if not sensitive or security related)
- email the Pylons Security mailing list: [email protected] (if security related)
Thanks
- m4yfly and urn1ce From TianGong Team of Legendsec at Qi'anxin Group.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | waitress | ≥ 2.0.0&&< 3.0.1 | 3.0.1pip install --upgrade 'waitress==3.0.1' |
Affected Products
waitressagendalessDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for waitress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update waitress to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-49768 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Disable `channel_request_lookahead`. This feature is disabled (set to 0) by default.Source: Red Hat security advisory for CVE-2024-49768 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Ironic content for Red Hat OpenShift Container Platform 4.12 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10535 |
| Ironic content for Red Hat OpenShift Container Platform 4.13 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10815 |
| Red Hat OpenShift Container Platform 4.14 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9623 |
| Red Hat OpenShift Container Platform 4.15 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:10145 |
| Red Hat OpenShift Container Platform 4.16 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9618 |
| Red Hat OpenShift Container Platform 4.17 | python-waitress-0:3.0.1-1.el9 | RHSA-2024:9613 |
| Red Hat OpenStack Platform 16.2 | python-waitress-0:2.0.0-4.el8ost | RHSA-2025:0201 |
| Red Hat OpenStack Platform 17.1 for RHEL 8 | python-waitress-0:2.0.0-4.el8ost | RHSA-2025:1192 |
Frequently Asked Questions
Is CVE-2024-49768 in your dependencies?
Find it across PyPI, including transitive dependencies.