CVE-2020-5236 is a medium-severity (CVSS 6.5) Uncontrolled Resource Consumption vulnerability in waitress. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for waitress — see the affected versions and patch details below.
Catastrophic backtracking in regex allows Denial of Service in Waitress
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
waitressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When waitress receives a header that contains invalid characters it will cause the regular expression engine to catastrophically backtrack causing the process to use 100% CPU time and blocking any other interactions.
This would allow an attacker to send a single request with an invalid header and take the service offline.
Invalid header example:
Bad-header: xxxxxxxxxxxxxxx\x10
Increasing the number of x's in the header will increase the amount of time Waitress spends in the regular expression engine.
This issue was introduced in version 1.4.2 when the regular expression was updated to attempt to match the behaviour required by errata associated with RFC7230.
Patches
The regular expression that is used to validate incoming headers has been updated in version 1.4.3, it is recommended that people upgrade to the new version of Waitress as soon as possible.
Workarounds
If you have deployed a reverse proxy in front of Waitress it may already be rejecting requests that include invalid headers.
Thanks
The Pylons Project would like to thank Fil Zembowicz for reaching out and disclosing this vulnerability!
References
Catastrophic backtracking explained: https://www.regular-expressions.info/catastrophic.html
For more information
If you have any questions or comments about this advisory:
- open an issue at https://github.com/Pylons/waitress/issues (if not sensitive or security related)
- email the Pylons Security mailing list: [email protected] (if security related)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | waitress | ≥ 1.4.2&&< 1.4.3 | 1.4.3pip install --upgrade 'waitress==1.4.3' |
Affected Products
waitressagendalessResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for waitress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update waitress to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5236 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2020-5236 in your dependencies?
Find it across PyPI, including transitive dependencies.