CVE-2024-46994 — basercms
MEDIUMCVE-2024-46994 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.
baserCMS has Cross-site Scripting Vulnerability in Blog posts and Contents list Feature
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-46994.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
baserproject/basercmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
XSS vulnerability in Blog posts and Contents list Feature to baserCMS.
Target
baserCMS 5.1.1 and earlier versions
Vulnerability
Malicious code may be executed in Blog posts and Contents list feature.
Countermeasures
Update to the latest version of baserCMS
Please refer to the following page to reference for more information. https://basercms.net/security/JVN_00876083
Credits
Kyohei Ota@LEON TECHNOLOGY,Inc.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | baserproject/basercms | all versions | 5.1.2composer require baserproject/basercms:^5.1.2 |
Affected Products
basercmsbasercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update baserproject/basercms to 5.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-46994 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-46994 in your dependencies?
Find it across Packagist, including transitive dependencies.