NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-30879 — basercms

CVE-2026-30879 is a Cross-site Scripting (XSS) vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.

baserCMS: Cross-site scripting vulnerability in blog post

Also known asGHSA-jmq3-x8q7-j9qm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-30879.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk-0.08%
Lower risk than most CVEs15th percentile — riskier than 15% of all scored CVEsHighest risk
0.00%0.27%0.55%0.82%0.0%0.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘baserproject/basercms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

baserCMS has a cross-site scripting vulnerability in blog posts.

Target

baserCMS 5.2.1 and earlier versions

Vulnerability

Malicious Javascript may be executed in blog posts.

Countermeasures

Update to the latest version of baserCMS

Please refer to the following page to reference for more information. https://basercms.net/security/JVN_20837860

Credits

Gai Tanaka@Mitsui Bussan Secure Directions, Inc.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbaserproject/basercmsall versions5.2.3composer require baserproject/basercms:^5.2.3

Affected Products

1 product · 1 configurations
Application
basercmsbasercms
< 5.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update baserproject/basercms to 5.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-30879 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

baserCMS has a cross-site scripting vulnerability in blog posts. ### Target baserCMS 5.2.1 and earlier versions ### Vulnerability Malicious Javascript may be executed in blog posts. ### Countermeasures Update to the latest version of baserCMS Please refer to the following page to reference for more information. https://basercms.net/security/JVN_20837860 ### Credits Gai Tanaka@Mitsui Bussan Secure Directions, Inc.
O3 Security · Impact-Aware SCA

Is CVE-2026-30879 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-30879: basercms XSS — Fixed in 5.2.3