NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2026-27697 — basercms

CVE-2026-27697 is a SQL Injection vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.

baserCMS: SQL injection vulnerability in blog post

Also known asGHSA-vh89-rjph-2g7p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27697.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘baserproject/basercms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

baserCMS has a SQL injection vulnerability in blog posts.

Target

baserCMS 5.2.2 and earlier versions

Vulnerability

Malicious SQL may be executed in blog posts.

Countermeasures

Update to the latest version of baserCMS

Please refer to the following page to reference for more information. https://basercms.net/security/JVN_52157568

Credits

Mirai Matsumoto@Future Secure Wave, Inc.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbaserproject/basercmsall versions5.2.3composer require baserproject/basercms:^5.2.3

Affected Products

1 product · 1 configurations
Application
basercmsbasercms
< 5.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update baserproject/basercms to 5.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27697 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

baserCMS has a SQL injection vulnerability in blog posts. ### Target baserCMS 5.2.2 and earlier versions ### Vulnerability Malicious SQL may be executed in blog posts. ### Countermeasures Update to the latest version of baserCMS Please refer to the following page to reference for more information. https://basercms.net/security/JVN_52157568 ### Credits Mirai Matsumoto@Future Secure Wave, Inc.
O3 Security · Impact-Aware SCA

Is CVE-2026-27697 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2026-27697: basercms SQL Injection — Fixed in 5.2.3