NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

baserCMS has a Cross-site Scripting (XSS) Vulnerability in Blog posts and Contents list FeatureGHSA-wrjc-fmfq-w3jr

MEDIUM

GHSA-wrjc-fmfq-w3jr is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in baserproject/basercms. A fix is available for baserproject/basercms — see the affected versions and patch details below.

Also known asCVE-2024-46994
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-wrjc-fmfq-w3jr.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.56%1.12%1.68%1.2%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘baserproject/basercms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

XSS vulnerability in Blog posts and Contents list Feature to baserCMS.

Target

baserCMS 5.1.1 and earlier versions

Vulnerability

Malicious code may be executed in Blog posts and Contents list feature.

Countermeasures

Update to the latest version of baserCMS

Please refer to the following page to reference for more information. https://basercms.net/security/JVN_00876083

Credits

Kyohei Ota@LEON TECHNOLOGY,Inc.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbaserproject/basercmsall versions5.1.2composer require baserproject/basercms:^5.1.2

Affected Products

1 product · 1 configurations
Application
basercmsbasercms
< 5.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for baserproject/basercms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update baserproject/basercms to 5.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-wrjc-fmfq-w3jr is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

XSS vulnerability in Blog posts and Contents list Feature to baserCMS. ### Target baserCMS 5.1.1 and earlier versions ### Vulnerability Malicious code may be executed in Blog posts and Contents list feature. ### Countermeasures Update to the latest version of baserCMS Please refer to the following page to reference for more information. https://basercms.net/security/JVN_00876083 ### Credits Kyohei Ota@LEON TECHNOLOGY,Inc.
O3 Security · Impact-Aware SCA

Is GHSA-wrjc-fmfq-w3jr in your dependencies?

Find it across Packagist, including transitive dependencies.

baserCMS has a Cross-site Scripting (XSS) Vulnerability in…