NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-45604 — core-bundle

MEDIUMFix: contao/contao@63409c6

CVE-2024-45604 is a medium-severity (CVSS 4.3) Path Traversal vulnerability in contao/core-bundle. A fix is available for contao/core-bundle — see the affected versions and patch details below.

Directory traversal in the file selector widget in contao/core-bundle

Also known asGHSA-4p75-5p53-65m9
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-45604.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.42%0.83%1.25%0.7%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘contao/core-bundle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Back end users can list files outside their file mounts or the document root in the FileSelector widget.

Patches

Update to Contao 4.13.49.

Workarounds

None.

References

https://contao.org/en/security-advisories/directory-traversal-in-the-fileselector-widget

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Credits

Thanks to Jakob Steeg from usd AG for reporting this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcontao/core-bundleall versions4.13.49composer require contao/core-bundle:^4.13.49

Affected Products

1 product · 1 configurations
Application
contaocontao
< 4.13.49
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for contao/core-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update contao/core-bundle to 4.13.49 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-45604 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact Back end users can list files outside their file mounts or the document root in the FileSelector widget. ### Patches Update to Contao 4.13.49. ### Workarounds None. ### References https://contao.org/en/security-advisories/directory-traversal-in-the-fileselector-widget ### For more information If you have any questions or comments about this advisory, open an issue in [contao/contao](https://github.com/contao/contao/issues/new/choose). ### Credits Thanks to Jakob Steeg from usd AG for reporting this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2024-45604 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-45604: core-bundle — Fixed in 4.13.49