NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2024-34069 — werkzeug

HIGHFix: pallets/werkzeug@3386395

CVE-2024-34069 is a high-severity (CVSS 7.5) Cross-Site Request Forgery (CSRF) vulnerability in werkzeug. A fix is available for werkzeug — see the affected versions and patch details below.

Werkzeug's improper usage of a pathname and improper CSRF protection results in the remote command execution

Also known asGHSA-2g68-c3qc-8985PYSEC-2026-2043
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-34069.

EPSS Exploitation Probability

via FIRST.org ↗
3.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%18.6%37.2%55.7%38.9%3.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍werkzeug

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Werkzeug is a comprehensive WSGI web application library. The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger. This vulnerability is fixed in 3.0.3.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIwerkzeugall versions3.0.3pip install --upgrade 'werkzeug==3.0.3'

Affected Products

3 products · 4 configurations
OS
debian linuxdebian
1 version
11.0
OS
fedorafedoraproject
2 versions
3840
Application
werkzeugpalletsprojects
< 3.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for werkzeug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update werkzeug to 3.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-34069 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Werkzeug's debugger allows an attacker to potentially execute code on a developer's machine. This can occur if the attacker tricks the developer into interacting with a controlled domain and subdomain and entering the debugger PIN. Although the debugger is meant to run locally, successful exploitation can give the…

Workaround published by Red Hat
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update the affected package as soon as possible.
Source: Red Hat security advisory for CVE-2024-34069 (CC BY 4.0)
ProductFixed inAdvisory
Ironic content for Red Hat OpenShift Container Platform 4.12python-werkzeug-0:2.0.3-6.el9RHSA-2024:5810
Red Hat Ceph Storage 7.1ceph-2:18.2.1-329.el8cpRHSA-2025:4664
Red Hat Ceph Storage 7.1rhceph/rhceph-7-rhel9:7-529RHSA-2025:9340
Red Hat OpenShift Container Platform 4.14openshift4/cloud-network-config-controller-rhel8:v4.14.0-202408260910.p0.g1bd0464.assembly.stream.el8RHSA-2024:6406
Red Hat OpenShift Container Platform 4.15python-werkzeug-0:2.2.3-3.el9RHSA-2024:6016
Red Hat OpenShift Container Platform 4.16openshift4/ose-ironic-rhel9:v4.16.0-202408051209.p0.ga428def.assembly.stream.el9RHSA-2024:5107
Red Hat OpenStack Platform 16.2python-werkzeug-0:0.14.1-13.el8ostRHSA-2024:10696
Red Hat OpenStack Platform 17.1 for RHEL 8python-werkzeug-0:2.0.1-9.el8ostRHSA-2024:9975

Frequently Asked Questions

Werkzeug is a comprehensive WSGI web application library. The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger. This vulnerability is fixed in 3.0.3.
O3 Security · Impact-Aware SCA

Is CVE-2024-34069 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2024-34069: werkzeug — Fixed in 3.0.3