CVE-2024-28175 is a critical-severity (CVSS 9) Cross-site Scripting (XSS) vulnerability in github.com/argoproj/argo-cd. A fix is available for github.com/argoproj/argo-cd — see the affected versions and patch details below.
Cross-site scripting on application summary component in argo-cd
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-28175.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/argoproj/argo-cd🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Summary
Due to the improper URL protocols filtering of links specified in the link.argocd.argoproj.io annotations in the application summary component, an attacker can achieve cross-site scripting with elevated permissions.
Impact
All unpatched versions of Argo CD starting with v1.0.0 are vulnerable to a cross-site scripting (XSS) bug allowing a malicious user to inject a javascript: link in the UI. When clicked by a victim user, the script will execute with the victim's permissions (up to and including admin).
This vulnerability allows an attacker to perform arbitrary actions on behalf of the victim via the API, such as creating, modifying, and deleting Kubernetes resources.
Patches
A patch for this vulnerability has been released in the following Argo CD versions:
- v2.10.3
- v2.9.8
- v2.8.12
Workarounds
There are no completely-safe workarounds besides upgrading. The safest alternative, if upgrading is not possible, would be to create a Kubernetes admission controller to reject any resources with an annotation starting with link.argocd.argoproj.io or reject the resource if the value use an improper URL protocol. This validation will need to be applied in all clusters managed by ArgoCD.
Mitigations
- Avoid clicking external links presented in the UI. The link's title is user-configurable. So even if you hover the link, and the tooltip looks safe, the link might be malicious. The only way to be certain that the link is safe is to inspect the page's source.
- Carefully limit who has permissions to edit Kubernetes resource manifests (this is configured in RBAC for ArgoCD). The external-links are set as annotations on Kubernetes resources. Any persona with write access to resources managed by ArgoCD could be an actor.
References
Documentation for the external links feature
Credits
Disclosed by RyotaK (@Ry0taK)
For more information
- Open an issue in the Argo CD issue tracker or discussions
- Join us on Slack in channel #argo-cd
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/argoproj/argo-cd | ≥ 1.0.0 | No fix |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.9.0&&< 2.9.8 | 2.9.8go get github.com/argoproj/argo-cd/v2@v2.9.8 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.10.0&&< 2.10.3 | 2.10.3go get github.com/argoproj/argo-cd/v2@v2.10.3 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.0.0&&< 2.8.12 | 2.8.12go get github.com/argoproj/argo-cd/v2@v2.8.12 |
Affected Products
argo cdargoprojDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/argoproj/argo-cd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
A fix is available for CVE-2024-28175; check the affected-versions list above or the advisory for the patched release of github.com/argoproj/argo-cd, then make sure no transitive dependency still pins the vulnerable range.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift GitOps 1.10 | openshift-gitops-1/argocd-rhel8:v1.10.3-2 | RHSA-2024:1345 |
| Red Hat OpenShift GitOps 1.11 | openshift-gitops-1/argocd-rhel8:v1.11.2-2 | RHSA-2024:1346 |
| Red Hat OpenShift GitOps 1.12 | openshift-gitops-1/argocd-rhel8:v1.12.0-19 | RHSA-2024:1441 |
Frequently Asked Questions
Is CVE-2024-28175 in your dependencies?
Find it across Go, including transitive dependencies.