CVE-2025-23216 is a medium-severity (CVSS 6.8) Information Exposure vulnerability in github.com/argoproj/argo-cd/v2. A fix is available for github.com/argoproj/argo-cd/v2 — see the affected versions and patch details below.
Argo CD does not scrub secret values from patch errors
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cd/v2🐹github.com/argoproj/argo-cdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability was discovered in Argo CD that exposed secret values in error messages and the diff view when an invalid Kubernetes Secret resource was synced from a repository.
The vulnerability assumes the user has write access to the repository and can exploit it, either intentionally or unintentionally, by committing an invalid Secret to repository and triggering a Sync. Once exploited, any user with read access to Argo CD can view the exposed secret data.
Patches
A patch for this vulnerability is available in the following Argo CD versions:
- v2.13.4
- v2.12.10
- v2.11.13
Workarounds
There is no workaround other than upgrading.
References
Fixed with commit https://github.com/argoproj/argo-cd/commit/6f5537bdf15ddbaa0f27a1a678632ff0743e4107 & https://github.com/argoproj/gitops-engine/commit/7e21b91e9d0f64104c8a661f3f390c5e6d73ddca
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.13.0&&< 2.13.4 | 2.13.4go get github.com/argoproj/argo-cd/v2@v2.13.4 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | ≥ 2.12.0&&< 2.12.10 | 2.12.10go get github.com/argoproj/argo-cd/v2@v2.12.10 |
| 🐹Go | github.com/argoproj/argo-cd/v2 | all versions | 2.11.13go get github.com/argoproj/argo-cd/v2@v2.11.13 |
| 🐹Go | github.com/argoproj/argo-cd | all versions | No fix |
Affected Products
argo cdargoprojDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/argoproj/argo-cd/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/argoproj/argo-cd/v2 to 2.13.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-23216 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2025-23216 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift GitOps 1.14 | openshift-gitops-1/argocd-rhel8:v1.14.3-4 | RHSA-2025:3069 |
| Red Hat OpenShift GitOps 1.15 | openshift-gitops-1/argocd-extensions-rhel8:v1.15.1-7 | RHSA-2025:1888 |
Frequently Asked Questions
Is CVE-2025-23216 in your dependencies?
Find it across Go, including transitive dependencies.