NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2024-21641 — core

MEDIUMFix: flarum/flarum-core@ee8b3b4

CVE-2024-21641 is a medium-severity (CVSS 6.5) Open Redirect vulnerability in flarum/core. A fix is available for flarum/core — see the affected versions and patch details below.

Flarum's Logout Route allows open redirects

Also known asGHSA-733r-8xcp-w9mr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-21641.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%16.8%33.7%50.5%32.8%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘flarum/core🐘flarum/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The Flarum /logout route includes a redirect parameter that allows any third party to redirect users from a (trusted) domain of the Flarum installation to redirect to any link. Sample: example.com/logout?return=https://google.com. For logged-in users, the logout must be confirmed. Guests are immediately redirected. This could be used by spammers to redirect to a web address using a trusted domain of a running Flarum installation.

Some ecosystem extensions modifying the logout route have already been affected. Sample: https://discuss.flarum.org/d/22229-premium-wordpress-integration/526

Patches

The vulnerability has been fixed and published as flarum/core v1.8.5. All communities running Flarum should upgrade as soon as possible to v1.8.5 using:

composer update --prefer-dist --no-dev -a -W

You can then confirm you run the latest version using:

composer show flarum/core

Workarounds

Some extensions modifying the logout route can remedy this issue if their implementation is safe. In any case we recommend updating to 1.8.5.

References

For any questions or comments on this vulnerability, please visit https://discuss.flarum.org/

For support questions, create a discussion at https://discuss.flarum.org/t/support.

A reminder that if you ever become aware of a security issue in Flarum, please report it to us privately by emailing [email protected], and we will address it promptly.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistflarum/coreall versions1.8.5composer require flarum/core:^1.8.5
🐘Packagistflarum/frameworkall versions1.8.5composer require flarum/framework:^1.8.5

Affected Products

1 product · 1 configurations
Application
flarumflarum
< 1.8.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flarum/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update flarum/core to 1.8.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-21641 is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

How to detect CVE-2024-21641

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-21641 -u https://target
Template
Flarum < 1.8.5 - Open Redirect
Severity
medium
Impact
Unauthenticated attackers can redirect users to malicious phishing sites using the trusted domain of the Flarum installation.
Remediation
Update Flarum to version 1.8.5 or later.

Template by ProjectDiscovery nuclei-templates (kking), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

### Impact The Flarum `/logout` route includes a redirect parameter that allows any third party to redirect users from a (trusted) domain of the Flarum installation to redirect to any link. Sample: `example.com/logout?return=https://google.com`. For logged-in users, the logout must be confirmed. Guests are immediately redirected. This could be used by spammers to redirect to a web address using a trusted domain of a running Flarum installation. Some ecosystem extensions modifying the logout route have already been affected. Sample: https://discuss.flarum.org/d/22229-premium-wordpress-integrat
O3 Security · Impact-Aware SCA

Is CVE-2024-21641 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2024-21641: core — Fixed in 1.8.5