resulted in an alert box appearing on the forum. This attack could also be modified to per"}},{"@type":"Question","name":"How severe is CVE-2021-32671?","acceptedAnswer":{"@type":"Answer","text":"CVE-2021-32671 has a CVSS score of 10/10, rated CRITICAL. Immediate patching is strongly recommended."}},{"@type":"Question","name":"Which packages are affected by CVE-2021-32671?","acceptedAnswer":{"@type":"Answer","text":"CVE-2021-32671 affects the following packages: flarum/core (Packagist). Ecosystems affected: Packagist."}},{"@type":"Question","name":"How do I fix CVE-2021-32671?","acceptedAnswer":{"@type":"Answer","text":"Update flarum/core to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32671 is resolved across your whole dependency graph."}},{"@type":"Question","name":"How do I detect CVE-2021-32671 in my Packagist dependencies?","acceptedAnswer":{"@type":"Answer","text":"Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flarum/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version."}},{"@type":"Question","name":"How do I mitigate CVE-2021-32671 if there is no patch (or I can't update yet)?","acceptedAnswer":{"@type":"Answer","text":"Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page."}},{"@type":"Question","name":"Is CVE-2021-32671 actively exploited in the wild?","acceptedAnswer":{"@type":"Answer","text":"No public exploit code has been indexed for CVE-2021-32671 yet. This does not mean the vulnerability cannot be exploited — absence of public exploits does not imply safety. Apply the recommended fix and use O3 Security to monitor your exposure."}},{"@type":"Question","name":"What is the EPSS score for CVE-2021-32671?","acceptedAnswer":{"@type":"Answer","text":"CVE-2021-32671 has an EPSS (Exploit Prediction Scoring System) score of 40.0%, placing it in the 99th percentile of all CVEs. EPSS is maintained by FIRST.org and estimates the probability that a vulnerability will be exploited in the wild within the next 30 days. This score warrants monitoring and prompt remediation."}},{"@type":"Question","name":"What type of vulnerability is CVE-2021-32671?","acceptedAnswer":{"@type":"Answer","text":"CVE-2021-32671 is classified as Cross-site Scripting (XSS) (CWE-79). This weakness type describe the underlying flaw category, which helps determine the potential impact and the right class of mitigation. This is a high-impact weakness class that often enables remote code execution or data exposure."}},{"@type":"Question","name":"When was CVE-2021-32671 published, and has it been updated?","acceptedAnswer":{"@type":"Answer","text":"CVE-2021-32671 was published on June 7, 2021 and was last updated on October 20, 2026. Advisory data evolves as severity scores, affected ranges, and exploit intelligence are revised — always check the latest version of the advisory before acting."}}]}
NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2021-32671 — core

CRITICALFix: flarum/core@440bed8

CVE-2021-32671 is a critical-severity (CVSS 10) Cross-site Scripting (XSS) vulnerability in flarum/core. EPSS puts its 30-day exploitation probability at 40.0% (99th percentile). A fix is available for flarum/core — see the affected versions and patch details below.

XSS vulnerability with translator

Also known asGHSA-5qjq-69w6-fg57
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
40.0%probability of exploitation in next 30 days
High Risk+0.26%
Lower risk than most CVEs99th percentile — riskier than 99% of all scored CVEsHighest risk
0.00%17.3%34.5%51.8%0.8%40.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘flarum/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented.

This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to perform AJAX requests on behalf of a user, possibly deleting discussions, modifying their settings or profile, or even modifying settings on the Admin panel if the attack was targetted towards a privileged user.

Impact

All Flarum communities that run flarum v1.0.0 or v1.0.1 are impacted.

Patches

The vulnerability has been fixed and published as flarum/core v1.0.2. All communities running Flarum v1.0 have to upgrade as soon as possible to v1.0.2 using:

composer update --prefer-dist --no-dev -a -W

You can then confirm you run the latest version using:

composer show flarum/core

Workarounds

None.

For more information

For any questions or comments on this vulnerability please visit https://discuss.flarum.org/d/27558.

For support questions create a discussion at https://discuss.flarum.org/t/support.

A reminder that if you ever become aware of a security issue in Flarum, please report it to us privately by emailing [email protected], and we will address it promptly.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistflarum/core≥ 1.0.0&&< 1.0.21.0.2composer require flarum/core:^1.0.2

Affected Products

1 product · 2 configurations
Application
flarumflarum
2 versions
1.0.01.0.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flarum/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update flarum/core to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32671 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Flarum's translation system allowed for string inputs to be converted into HTML DOM nodes when rendered. This change was made after v0.1.0-beta.16 (our last beta before v1.0.0) and was not noticed or documented. This allowed for any user to type malicious HTML markup within certain user input fields and have this execute on client browsers. The example which led to the discovery of this vulnerability was in the forum search box. Entering faux-malicious HTML markup, such as <script>alert('test')</script> resulted in an alert box appearing on the forum. This attack could also be modified to per
O3 Security · Impact-Aware SCA

Is CVE-2021-32671 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-32671: core — Fixed in 1.0.2