NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2023-5968 — mattermost-server

MEDIUMFix: mattermost/mattermost#24362

CVE-2023-5968 is a medium-severity (CVSS 4.9) Information Exposure vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Password hash in response body after username update

Also known asGHSA-r67m-mf7v-qp7j
Published
Updated
Affected
8 pkgs
Patched
8 / 8
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-5968.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.67%1.01%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v5🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost fails to properly sanitize the user object when updating the username, resulting in the password hash being included in the response body. 

Affected Packages

8 total 8 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 5.4.0-rc1&&< 7.8.127.8.12go get github.com/mattermost/mattermost-server/v6@v7.8.12
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 8.0.0&&< 8.0.48.0.4go get github.com/mattermost/mattermost/server/v8@v8.0.4
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 8.1.0&&< 8.1.38.1.3go get github.com/mattermost/mattermost/server/v8@v8.1.3
🐹Gogithub.com/mattermost/mattermost/server/v8≥ 9.0.0&&< 9.0.19.0.1go get github.com/mattermost/mattermost/server/v8@v9.0.1
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20230825233148-f787fd63368ago get github.com/mattermost/mattermost/server/v8@v8.0.0-20230825233148-f787fd63368a
🐹Gogithub.com/mattermost/mattermost-server/v6all versions5.3.2-0.20230825233148-f787fd63368ago get github.com/mattermost/mattermost-server/v6@v5.3.2-0.20230825233148-f787fd63368a

Affected Products

1 product · 4 configurations
Application
mattermostmattermost
≥ 8.1.0 && ≤ 8.1.2
1 version
9.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 7.8.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-5968 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Mattermost fails to properly sanitize the user object when updating the username, resulting in the password hash being included in the response body. 
O3 Security · Impact-Aware SCA

Is CVE-2023-5968 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-5968: mattermost-server — Fixed in 7.8.12