NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2025-53971 — mattermost-server

LOW

CVE-2025-53971 is a low-severity (CVSS 3.8) CWE-863 vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Channel and Team Membership APIs inadvertently allow loss of Member privileges.

Also known asGHSA-4276-cm8c-788hGO-2025-3902
Published
Updated
Affected
5 pkgs
Patched
3 / 5
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-53971.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk
0.00%0.23%0.47%0.70%0.0%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost/server/v8🐹github.com/mattermost/mattermost-server/v5🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate authorization for team scheme role modifications which allows Team Admins to demote Team Members to Guests via the PUT /api/v4/teams/team-id/members/user-id/schemeRoles API endpoint.

Affected Packages

5 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server≥ 10.5.0&&< 10.5.910.5.9go get github.com/mattermost/mattermost-server@v10.5.9
🐹Gogithub.com/mattermost/mattermost-server≥ 9.11.0&&< 9.11.189.11.18go get github.com/mattermost/mattermost-server@v9.11.18
🐹Gogithub.com/mattermost/mattermost/server/v8all versions8.0.0-20250721095846-c602a4a78e1fgo get github.com/mattermost/mattermost/server/v8@v8.0.0-20250721095846-c602a4a78e1f
🐹Gogithub.com/mattermost/mattermost-server/v5all versionsNo fix
🐹Gogithub.com/mattermost/mattermost-server/v6all versionsNo fix

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
≥ 10.5.0 && < 10.5.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 10.5.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-53971 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate authorization for team scheme role modifications which allows Team Admins to demote Team Members to Guests via the PUT /api/v4/teams/team-id/members/user-id/schemeRoles API endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2025-53971 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2025-53971: mattermost-server — Fixed in 10.5.9