CVE-2023-46589 is a high-severity (CVSS 7.5) CWE-444 vulnerability in org.apache.tomcat:tomcat-catalina. A fix is available for org.apache.tomcat:tomcat-catalina — see the affected versions and patch details below.
Apache Tomcat: HTTP request smuggling via malformed trailer headers
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-46589.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat:tomcat-catalina☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core☕org.apache.tomcat.embed:tomcat-embed-core+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy.
Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 11.0.0-M1&&< 11.0.0-M11 | 11.0.0-M11org.apache.tomcat:tomcat-catalina:11.0.0-M11 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1&&< 10.1.16 | 10.1.16org.apache.tomcat:tomcat-catalina:10.1.16 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 9.0.0-M1&&< 9.0.83 | 9.0.83org.apache.tomcat:tomcat-catalina:9.0.83 |
| ☕Maven | org.apache.tomcat:tomcat-catalina | ≥ 8.5.0&&< 8.5.96 | 8.5.96org.apache.tomcat:tomcat-catalina:8.5.96 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 11.0.0-M1&&< 11.0.0-M11 | 11.0.0-M11org.apache.tomcat.embed:tomcat-embed-core:11.0.0-M11 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1&&< 10.1.16 | 10.1.16org.apache.tomcat.embed:tomcat-embed-core:10.1.16 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-catalina, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-catalina to 11.0.0-M11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-46589 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability in Apache Tomcat is of significant importance due to its potential to exploit HTTP request smuggling, presenting a security risk for web applications utilizing Tomcat. The flaw arises from Tomcat's improper parsing of HTTP trailer headers, where a specifically crafted header exceeding the size limit…
Mitigation for this issue is either not available or the currently available options don't meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2023-46589 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| JWS 5.7.8 | tomcat | RHSA-2024:1319 |
| JWS 6.0.1 | tomcat | RHSA-2024:1325 |
| Red Hat Enterprise Linux 10 | tomcat-1:10.1.36-1.el10_0 | RHSA-2025:7497 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.62-27.el8_9.3 | RHSA-2024:0539 |
| Red Hat Enterprise Linux 8.8 Extended Update Support | tomcat-1:9.0.62-5.el8_8.3 | RHSA-2024:0532 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.62-37.el9_3.2 | RHSA-2024:1134 |
| Red Hat Enterprise Linux 9.2 Extended Update Support | tomcat-1:9.0.62-11.el9_2.4 | RHSA-2024:1092 |
| Red Hat Fuse 7.13.0 | tomcat | RHSA-2024:3354 |
Frequently Asked Questions
Is CVE-2023-46589 in your dependencies?
Find it across Maven, including transitive dependencies.