NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2023-44309 — com.liferay.fragment.entr…

MEDIUMFix: liferay/liferay-portal@1287c68

CVE-2023-44309 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.fragment.entry.processor.impl. A fix is available for com.liferay:com.liferay.fragment.entry.processor.impl — see the affected versions and patch details below.

Liferay Portal and Liferay DXP Vulnerable to XSS in the Fragment Components

Also known asBIT-liferay-2023-44309GHSA-j663-6jpj-xx8c
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-44309.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.11%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.36%0.72%1.08%0.2%0.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕com.liferay:com.liferay.fragment.entry.processor.impl☕com.liferay.portal:release.dxp.bom

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Multiple stored cross-site scripting (XSS) vulnerabilities in the fragment components before 3.0.25 from Liferay Portal (7.4.2 through 7.4.3.53), and Liferay DXP 7.4 before update 54 allow remote attackers to inject arbitrary web script or HTML via a crafted payload injected into any non-HTML field of a linked source asset.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.fragment.entry.processor.implall versions3.0.25com.liferay:com.liferay.fragment.entry.processor.impl:3.0.25
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.4.0&&< 7.4.13.u547.4.13.u54com.liferay.portal:release.dxp.bom:7.4.13.u54

Affected Products

2 products · 10 configurations
Application
digital experience platformliferay
1 version
7.4
Application
liferay portalliferay
≥ 7.4.2 && < 7.4.3.53
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.fragment.entry.processor.impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.fragment.entry.processor.impl to 3.0.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-44309 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple stored cross-site scripting (XSS) vulnerabilities in the fragment components before 3.0.25 from Liferay Portal (7.4.2 through 7.4.3.53), and Liferay DXP 7.4 before update 54 allow remote attackers to inject arbitrary web script or HTML via a crafted payload injected into any non-HTML field of a linked source asset.
O3 Security · Impact-Aware SCA

Is CVE-2023-44309 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2023-44309: com.liferay.fragment — Fixed in 3.0.25