NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-3760 — release.portal.bom

MEDIUM

CVE-2025-3760 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.

Liferay Cross-site Scripting vulnerability

Also known asGHSA-qhp6-vp7c-g7xp
Published
Updated
Affected
13 pkgs
Patched
4 / 13
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-3760.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.26%0.52%0.77%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

13 pkgs affected
☕com.liferay.portal:release.portal.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom☕com.liferay.portal:release.dxp.bom+5 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A stored cross-site scripting (XSS) vulnerability exists with radio button type custom fields in Liferay Portal 7.2.0 through 7.4.3.129, and Liferay DXP 2024.Q4.1 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.9, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.12, 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, 7.3 GA through update 36, and 7.2 GA through fix pack 20 allows remote authenticated attackers to inject malicious JavaScript into a page.

Affected Packages

13 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay.portal:release.portal.bom≥ 7.2.0&&< 7.4.3.1327.4.3.132com.liferay.portal:release.portal.bom:7.4.3.132
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.2.10.fp1No fix
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.3.10.ep1No fix
☕Mavencom.liferay.portal:release.dxp.bom≥ 7.4.13.u1No fix
☕Mavencom.liferay.portal:release.dxp.bom≥ 2023.Q3.1No fix
☕Mavencom.liferay.portal:release.dxp.bom≥ 2023.Q4.0No fix

Affected Products

2 products · 5 configurations
Application
digital experience platformliferay
≥ 2024.Q4.0 && ≤ 7.4
range
Application
liferay portalliferay
≥ 7.2.0 && ≤ 7.4.3.129
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay.portal:release.portal.bom to 7.4.3.132 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-3760 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A stored cross-site scripting (XSS) vulnerability exists with radio button type custom fields in Liferay Portal 7.2.0 through 7.4.3.129, and Liferay DXP 2024.Q4.1 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.9, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.12, 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, 7.3 GA through update 36, and 7.2 GA through fix pack 20 allows remote authenticated attackers to inject malicious JavaScript into a page.
O3 Security · Impact-Aware SCA

Is CVE-2025-3760 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-3760: release.portal XSS — Fixed in 7.4.3.132