NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
LOW severity

CVE-2023-4105 — mattermost-server

LOW

CVE-2023-4105 is a low-severity (CVSS 3.1) CWE-862 vulnerability in github.com/mattermost/mattermost-server/v6. A fix is available for github.com/mattermost/mattermost-server/v6 — see the affected versions and patch details below.

Attachment of deleted message in a thread remains accessible and downloadable

Also known asGHSA-g3v6-r8p9-wxg9
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-4105.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.3%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6🐹github.com/mattermost/mattermost-server/v6

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Mattermost fails to delete the attachments when deleting a message in a thread allowing a simple user to still be able to access and download the attachment of a deleted message

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 7.9.0&&< 7.9.67.9.6go get github.com/mattermost/mattermost-server/v6@v7.9.6
🐹Gogithub.com/mattermost/mattermost-server/v6≥ 7.10.0&&< 7.10.47.10.4go get github.com/mattermost/mattermost-server/v6@v7.10.4
🐹Gogithub.com/mattermost/mattermost-server/v6all versions7.8.8go get github.com/mattermost/mattermost-server/v6@v7.8.8

Affected Products

1 product · 3 configurations
Application
mattermostmattermost
≥ 7.10.0 && < 7.10.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server/v6, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server/v6 to 7.9.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-4105 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Mattermost fails to delete the attachments when deleting a message in a thread allowing a simple user to still be able to access and download the attachment of a deleted message
O3 Security · Impact-Aware SCA

Is CVE-2023-4105 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2023-4105: mattermost-server — Fixed in 7.9.6