NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2023-38037 — activesupport

MEDIUMFix: rails/rails@a21d6ed

CVE-2023-38037 is a medium-severity (CVSS 5.5) CWE-732 vulnerability in activesupport. A fix is available for activesupport — see the affected versions and patch details below.

Active Support Possibly Discloses Locally Encrypted Files

Also known asGHSA-cr5q-6q9f-rq6q
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-38037.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.26%0.52%0.77%0.1%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎activesupport💎activesupport

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

There is a possible file disclosure of locally encrypted files in Active Support. This vulnerability has been assigned the CVE identifier CVE-2023-38037.

Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.7.1, 6.1.7.5

Impact

ActiveSupport::EncryptedFile writes contents that will be encrypted to a temporary file. The temporary file’s permissions are defaulted to the user’s current umask settings, meaning that it’s possible for other users on the same system to read the contents of the temporary file.

Attackers that have access to the file system could possibly read the contents of this temporary file while a user is editing it.

All users running an affected release should either upgrade or use one of the workarounds immediately.

Releases

The fixed releases are available at the normal locations.

Workarounds

To work around this issue, you can set your umask to be more restrictive like this:

$ umask 0077

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsactivesupport≥ 5.2.0&&< 6.1.7.56.1.7.5bundle update activesupport --conservative
💎RubyGemsactivesupport≥ 7.0.0&&< 7.0.7.17.0.7.1bundle update activesupport --conservative

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activesupport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update activesupport to 6.1.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-38037 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
Workaround published by Red Hat
To work around this issue, users can set their umask to be more restrictive: $ umask 0077
Source: Red Hat security advisory for CVE-2023-38037 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Satellite 6.15 for RHEL 8rubygem-activesupport-0:6.1.7.6-1.el8satRHSA-2024:2010
RHOL-5.7-RHEL-8openshift-logging/fluentd-rhel8:v1.14.6-203RHSA-2024:0268
RHOL-5.8-RHEL-9openshift-logging/fluentd-rhel9:v5.8.1-9RHSA-2023:7720

Frequently Asked Questions

There is a possible file disclosure of locally encrypted files in Active Support. This vulnerability has been assigned the CVE identifier CVE-2023-38037. Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.7.1, 6.1.7.5 # Impact ActiveSupport::EncryptedFile writes contents that will be encrypted to a temporary file. The temporary file’s permissions are defaulted to the user’s current umask settings, meaning that it’s possible for other users on the same system to read the contents of the temporary file. Attackers that have access to the file system could possibly read the c
O3 Security · Impact-Aware SCA

Is CVE-2023-38037 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2023-38037: activesupport — Fixed in 6.1.7.5