NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

CVE-2013-1856 — activesupport

CVE-2013-1856 is a Improper Input Validation vulnerability in activesupport. A fix is available for activesupport — see the affected versions and patch details below.

activesupport Improper Input Validation vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.21%0.99%1.77%2.55%0.7%2.1%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
💎activesupport💎activesupport

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The ActiveSupport::XmlMini_JDOM backend in lib/active_support/xml_mini/jdom.rb in the Active Support component in Ruby on Rails 3.0.x and 3.1.x before 3.1.12 and 3.2.x before 3.2.13, when JRuby is used, does not properly restrict the capabilities of the XML parser, which allows remote attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving (1) an external DTD or (2) an external entity declaration in conjunction with an entity reference.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsactivesupport≥ 3.0.0&&< 3.1.123.1.12bundle update activesupport --conservative
💎RubyGemsactivesupport≥ 3.2.0&&< 3.2.133.2.13bundle update activesupport --conservative

Affected Products

2 products · 47 configurations
Application
railsrubyonrails
24 versions
3.1.03.1.13.1.23.1.33.1.43.1.53.1.63.1.73.1.83.1.93.1.103.2.0
Application
ruby on railsrubyonrails
1 version
3.1.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for activesupport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update activesupport to 3.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1856 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The `ActiveSupport::XmlMini_JDOM` backend in `lib/active_support/xml_mini/jdom.rb` in the Active Support component in Ruby on Rails 3.0.x and 3.1.x before 3.1.12 and 3.2.x before 3.2.13, when JRuby is used, does not properly restrict the capabilities of the XML parser, which allows remote attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving (1) an external DTD or (2) an external entity declaration in conjunction with an entity reference.
O3 Security · Impact-Aware SCA

Is CVE-2013-1856 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-1856: activesupport DoS — Fixed in 3.1.12