CVE-2023-31125 is a medium-severity (CVSS 6.5) CWE-248 vulnerability in engine.io. A fix is available for engine.io — see the affected versions and patch details below.
Uncaught exception in engine.io
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31125.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
engine.ionpmDescription
Impact
A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process.
TypeError: Cannot read properties of undefined (reading 'handlesUpgrades')
at Server.onWebSocket (build/server.js:515:67)
This impacts all the users of the engine.io package, including those who uses depending packages like socket.io.
Patches
A fix has been released today (2023/05/02): 6.4.2
This bug was introduced in version 5.1.0 and included in version 4.1.0 of the socket.io parent package. Older versions are not impacted.
For socket.io users:
| Version range | engine.io version | Needs minor update? |
|---|---|---|
[email protected] | ~6.4.0 | npm audit fix should be sufficient |
[email protected] | ~6.2.0 | Please upgrade to [email protected] |
[email protected] | ~6.1.0 | Please upgrade to [email protected] |
[email protected] | ~6.0.0 | Please upgrade to [email protected] |
[email protected] | ~5.2.0 | Please upgrade to [email protected] |
[email protected] | ~5.1.1 | Please upgrade to [email protected] |
[email protected] | ~5.0.0 | Not impacted |
[email protected] | ~4.1.0 | Not impacted |
[email protected] | ~4.0.0 | Not impacted |
[email protected] | ~3.6.0 | Not impacted |
[email protected] and below | ~3.5.0 | Not impacted |
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open an issue in
engine.io
Thanks to Thomas Rinsma from Codean for the responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | engine.io | ≥ 5.1.0&&< 6.4.2 | 6.4.2npm install engine.io@6.4.2 |
Affected Products
engine.iosocketDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for engine.io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update engine.io to 6.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31125 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2023-31125 in your dependencies?
Find it across npm, including transitive dependencies.