CVE-2022-41940 is a high-severity (CVSS 7.1) CWE-248 vulnerability in engine.io. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for engine.io — see the affected versions and patch details below.
Uncaught exception in engine.io
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
engine.ionpmDescription
Impact
A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process.
events.js:292
throw er; // Unhandled 'error' event
^
Error: read ECONNRESET
at TCP.onStreamRead (internal/stream_base_commons.js:209:20)
Emitted 'error' event on Socket instance at:
at emitErrorNT (internal/streams/destroy.js:106:8)
at emitErrorCloseNT (internal/streams/destroy.js:74:3)
at processTicksAndRejections (internal/process/task_queues.js:80:21) {
errno: -104,
code: 'ECONNRESET',
syscall: 'read'
}
This impacts all the users of the engine.io package, including those who uses depending packages like socket.io.
Patches
A fix has been released today (2022/11/20):
| Version range | Fixed version |
|---|---|
[email protected] | 3.6.1 |
[email protected] | 6.2.1 |
For socket.io users:
| Version range | engine.io version | Needs minor update? |
|---|---|---|
[email protected] | ~6.2.0 | npm audit fix should be sufficient |
[email protected] | ~6.1.0 | Please upgrade to [email protected] |
[email protected] | ~6.0.0 | Please upgrade to [email protected] |
[email protected] | ~5.2.0 | Please upgrade to [email protected] |
[email protected] | ~5.1.1 | Please upgrade to [email protected] |
[email protected] | ~5.0.0 | Please upgrade to [email protected] |
[email protected] | ~4.1.0 | Please upgrade to [email protected] (see here) |
[email protected] | ~4.0.0 | Please upgrade to [email protected] (see here) |
[email protected] | ~3.6.0 | npm audit fix should be sufficient |
[email protected] and below | ~3.5.0 | Please upgrade to [email protected] |
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open an issue in
engine.io
Thanks to Jonathan Neve for the responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | engine.io | all versions | 3.6.1npm install engine.io@3.6.1 |
| 📦npm | engine.io | ≥ 4.0.0&&< 6.2.1 | 6.2.1npm install engine.io@6.2.1 |
Affected Products
engine.iosocketResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for engine.io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update engine.io to 3.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41940 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.12 | engine.io | RHSA-2023:3954 |
Frequently Asked Questions
Is CVE-2022-41940 in your dependencies?
Find it across npm, including transitive dependencies.