CVE-2022-21676 is a high-severity (CVSS 7.5) CWE-754 vulnerability in engine.io. A fix is available for engine.io — see the affected versions and patch details below.
Uncaught Exception in engine.io
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21676.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
engine.ionpmDescription
Impact
A specially crafted HTTP request can trigger an uncaught exception on the Engine.IO server, thus killing the Node.js process.
RangeError: Invalid WebSocket frame: RSV2 and RSV3 must be clear at Receiver.getInfo (/.../node_modules/ws/lib/receiver.js:176:14) at Receiver.startLoop (/.../node_modules/ws/lib/receiver.js:136:22) at Receiver._write (/.../node_modules/ws/lib/receiver.js:83:10) at writeOrBuffer (internal/streams/writable.js:358:12)
This impacts all the users of the engine.io package starting from version 4.0.0, including those who uses depending packages like socket.io.
Patches
A fix has been released for each major branch:
| Version range | Fixed version |
|---|---|
[email protected] | 4.1.2 |
[email protected] | 5.2.1 |
[email protected] | 6.1.1 |
Previous versions (< 4.0.0) are not impacted.
For socket.io users:
| Version range | engine.io version | Needs minor update? |
|---|---|---|
[email protected] | ~6.1.0 | - |
[email protected] | ~6.0.0 | Please upgrade to [email protected] |
[email protected] | ~5.2.0 | - |
[email protected] | ~5.1.1 | Please upgrade to [email protected] |
[email protected] | ~5.0.0 | Please upgrade to [email protected] |
[email protected] | ~4.1.0 | - |
[email protected] | ~4.0.0 | Please upgrade to [email protected] or [email protected] (see here) |
In most cases, running npm audit fix should be sufficient. You can also use npm update engine.io --depth=9999.
Workarounds
There is no known workaround except upgrading to a safe version.
For more information
If you have any questions or comments about this advisory:
- Open an issue in
engine.io
Thanks to Marcus Wejderot from Mevisio for the responsible disclosure.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | engine.io | ≥ 4.0.0&&< 4.1.2 | 4.1.2npm install engine.io@4.1.2 |
| 📦npm | engine.io | ≥ 5.0.0&&< 5.2.1 | 5.2.1npm install engine.io@5.2.1 |
| 📦npm | engine.io | ≥ 6.0.0&&< 6.1.1 | 6.1.1npm install engine.io@6.1.1 |
Affected Products
engine.iosocketDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for engine.io, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update engine.io to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21676 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-21676 in your dependencies?
Find it across npm, including transitive dependencies.